Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Failed to mount database 'Public Folder Database 1471458426'.

To whom it may respond to,

While trying to setup exchange 2010 at command :

New-MailboxDatabase -Server 'EXCSRV1' -Name 'Database02' -EdbFilePath 'C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Database02\Database02.edb' -LogFolderPath 'C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Database02'

I got this error:

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
Failed to mount database 'Public Folder Database 1471458426'.

Public Folder Database 1471458426
Failed
Error:
Couldn't mount the database that you specified. Specified database: Public Folder Database 1471458426; Error code: An Active Manager operation failed. Error: The database action failed. Error: The mount operation is being prevented for database 'Public Folder Database 1471458426' because its database file at 'C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Public Folder Database 1471458426\Public Folder Database 1471458426.edb' is missing, but still has transaction log files, with the highest generation number being 0x13. Please either recover the database file from a backup, or remove the log files if your intention is to mount a newly-created empty database.. [Database: Public Folder Database 1471458426, Server: EXCSRVM.fasdat.com].

There are .jrs files , .jhk files and some other binary files but there are no .log files.

What are the steps to recover from this step and continue to setup?

share|improve this question
    
Ben, thank you for formatting. –  kayhan yüksel Sep 27 '11 at 21:07
add comment

2 Answers

If you don't want that public folder database, simply do what it says and delete the .log files associated with the database, which IIRC should be in a folder of their own. I'd recommend moving them somewhere safe for a while rather than deleting them - just in case.

If you deleted the .edb file yourself, then you should be fine to delete the log files too (make sure you deleted it from the Exchange Management Console as well). If you didn't delete the .edb file it complains is missing, you may have something more peculiar going on that should probably be investigated.

share|improve this answer
    
not deleted edb on purpose, seems to be deleted after the command. will try to do as you have told to. thank you for your concern. will post the results. –  kayhan yüksel Sep 27 '11 at 21:40
    
sorry had to delete all config and start over. –  kayhan yüksel Oct 4 '11 at 21:49
add comment

Hopefully you have a backup, and you will need to restore the .ebd file from that backup. Then once you start the services and mount the database, exchange should automatically go into recovery mode and roll the log files back onto the .edb file to bring it current.

share|improve this answer
    
What if there is no backup, since it is a new installation and shadow volume is disabled? –  kayhan yüksel Sep 27 '11 at 21:10
    
We are trying to do this installation on Vmware Essentials Plus, does it make difference on requirements? –  kayhan yüksel Sep 27 '11 at 21:12
    
VMWare should not make a difference; if this is a new installation, and there is nothing in the Public Folders Database that you require, then you can simply delete the PFD from the Exchange Management Console. –  Coding Gorilla Sep 28 '11 at 13:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.