Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Running on a Snow Leopard MacBook air, can't browse the web (in any browser, tried FF,Chrome,Safari) using DNS names that are either already cached in DNS or not. Browsing to google.com or thisisnotincache.com both result in the browser reporting a "not connected to the internet" page. Ok, DNS resolution we're all thinking...nope. Terminal I can ping, trace, nslookup, and everything else all of these DNS names (those that exist in cache, those that don't, flushing cache, etc. all still resolve just fine) on all DNS servers. Still, browsing in a web browser DOES work if I use actual IP's as the address rather than a DNS name (i.e. http://72.14.204.105) works just fine. Even more odd, I pull up Terminal and try using Curl to "browse" by DNS name, and that works just fine (in addition to by IP).

I've triple checked proxy settings (and none are being used anywhere on any network), I've tried using different DNS servers, I've removed all filter drivers that were there (i.e. software VPN, Firewalls, etc.), and turned of nearly everything I can think of that would even remotely possibly contribute to anything.

Naturally, I'm now running a malware/virus scan to be thorough, but that's been running for an hour with nothing found yet, though who knows.

[EDIT]: Some additional info in response to comments. Yes, rebooted, no luck. Verified proxy settings (no proxies anywhere, OS level, browser, etc.). Other applications are working fine (skype, dropbox, email apps, etc.). Literally, all I can seem to find that isn't "working" is browsing the web with any web browser by DNS name.

share|improve this question

closed as off topic by Shane Madden, GregD, quanta, Wesley, Scott Pack Sep 28 '11 at 14:37

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What does nslookup google.com say? Did you try with a command line web browser: links, lynx, ...? –  quanta Sep 28 '11 at 0:25
    
nslookup works fine (see above), didn't try any of those cmdline browsers, but did work fine with CURL (see above). I'll try one of those for kicks...I'll try anything at this point. –  chadhoc Sep 28 '11 at 0:33
    
Have you rebooted? That can resolve issues with mDNSResponder –  GregD Sep 28 '11 at 0:33
    
, especially after a suspend state. You can also try sudo killall mDNSResponder –  GregD Sep 28 '11 at 0:38
    
do you by any chance have a sonicwall vpn client installed on your machine? –  GregD Sep 28 '11 at 0:59

1 Answer 1

Because it doesn't work with multiple browsers ..

  • Did you checked the proxy settings at the OS GUI level ?
  • I guess you tried to logoff from your session already ?
  • What about email application / ftp client / etc ?
share|improve this answer
    
Yep, tried those...good points though, just added info to the question. –  chadhoc Sep 28 '11 at 0:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.