Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

In php.ini I have set "max_execution_time = 1200", phpinfo() confirms that, but my script stops after 300 seconds with message:

"PHP Fatal error: Maximum execution time of 300 seconds exceeded"

Nginx fastcgi_read_timeout is also set to 1200, however I think its more php issue. How to fix that problem?

edit:

It was CodeIgniter framework - it was setting max_execution_time to 300. Thank you for help. :)

share|improve this question
    
If you echo ini_get('max_execution_time'); from within the script does it output 300 or 1200? I'm just wondering if for some reason your script is using another ini file or no ini file. –  DaveRandom Sep 28 '11 at 8:58

1 Answer 1

up vote 0 down vote accepted

Make sure that you didn't use set_time_limit in your PHP code.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.