Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So i am trying to access my site using my ip address xx.xx.xxx.xx (don't think it's a good idea to give it out). But i get Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data. Here is what i have tried so far:

Made sure that the site works on localhost. Forwarded port 80 on my router to my computer. Checked canyouseeme.org to make sure port 80 is open on my computer, it works fine. Tried to ping my computer ip address from work and it doesn't seem to work. What am i doing wrong ? I recently reinstalled WAMP and it was working fine before, not sure what changed :-/ Any help would be appreciated. Thanks!

share|improve this question
add comment

4 Answers 4

up vote 0 down vote accepted

Since you state that it worked before (presumably from offsite) and the 324 error appears to be a clientside issue specific to Google Chrome, I would first try loading the site in a different browser(s). If you get the same results then confirm the details of the web servers socket with netstat -noab|find /i "listen"|find /i ":80". I would want to rule out that the socket is not binding to 127.0.0.1:80 or something similar.

share|improve this answer
    
First off, thanks for your input. I tried different browsers but no luck. I ran the command you stated, here's what i got TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 908 –  Interstellar_Coder Sep 28 '11 at 15:05
    
The netstat output looks good, did the other browsers give you the same error? –  Somantra Sep 28 '11 at 15:09
    
Firefox says The connection was reset The connection to the server was reset while the page was loading.` –  Interstellar_Coder Sep 28 '11 at 15:34
    
OK, at this point I would scrutinize the router. First just try resetting the modem/router then if that yields nothing, you could save your router config settings then restore default settings, then configure your port-forwarding setup. –  Somantra Sep 28 '11 at 16:04
    
Thank you very much, it was the dang router. –  Interstellar_Coder Sep 28 '11 at 19:44
add comment

Do you have another computer on the same network? If so, can that computer access your webserver? That's your first step, then worry about being visible to the outside world.

share|improve this answer
    
Unfortunately i'm not at home right now, but i will try this suggesting when i do get home. –  Interstellar_Coder Sep 28 '11 at 14:59
add comment

If you're running this on a consumer ISP line it is entirely possible that your ISP is blocking well-known ports to prevent you from running servers (which is undoubtedly against your Terms of Service).

ISPs generally are not terribly smart, though, and only block well known ports. I would try reconfiguring Apache to listen on some port other than 80 (like 81, or 8181), reconfigure your router to forward that port to your computer and try it again.

share|improve this answer
    
Why reconfigure Apache when OP said port 80 was visible via canyouseeme.org? –  DKNUCKLES Sep 28 '11 at 14:51
    
Because in some cases instead of outright blocking a port, the ISP will traffic shape to drop outgoing packets. In that case, a simple port scan will show the port as open, but you will not succeed in getting any traffic back on that port. –  jdw Sep 28 '11 at 14:55
add comment

My first suggestion would be to try another browser other than Chrome to ensure that this isn't just a Google Chrome cache issue.

It doesn't look to be a firewall issue due to the fact it can be seen externally from canyouseeme.org.A quick google search of net::err_empty_response points to the fact that this is a Google Chrome issue and not necessarily a web server issues.

share|improve this answer
    
I tried it from firefox and ie too, no luck :-( –  Interstellar_Coder Sep 28 '11 at 15:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.