Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Possible Duplicate:
How do I get apt-get to ignore some dependencies?

I need to install some packages.

The package A has the package B as a dependency and requires to be (>2.0).

I have already installed in my system the package B version 2.1. But there is a new version (2.2) of the B package in the Debian repository and i don't want it since it conflicts with other stuff.

So, if i install the A package it also installs B because is its dependency, the problem here is that apt-get is also upgrading the B package and installing the new version that i don't want (2.2).

How can i disable the upgrading of the dependencies or indicate an explicit dependency version without having to edit the packages?

share|improve this question

marked as duplicate by sysadmin1138 Sep 28 '11 at 14:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
Is not duplicated, so i'm going to anwser myself, use: --no-upgrade –  VictorTuenti Sep 28 '11 at 14:55

2 Answers 2

You can try the --nodeps flag with apt-get or you can try the debian package utility, dpkg, with the option --ignore-depends.

share|improve this answer

You can either use the --nodeps flag with apt-get or download the package and install it using dpkg along with the option --ignore-depends

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.