Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have set up receive connector on my Exchange 2010 server to receive email from my Nagios box. I have an external email address in my contacts for nagios to convert emails to text. It seems exchange is refusing to relay mail to an external address but it will relay fine if the address is internal. Are there any other places to look for settings besides the hub transport rules? I also have the receive connecter set up for anonymous login. Any ideas?

share|improve this question
    
What do you mean that it won't relay for an external address? So you're sending an email from Outlook(?) to my-email@nagios.local and it rejects it? –  Coding Gorilla Sep 28 '11 at 15:48
add comment

1 Answer

up vote 1 down vote accepted

Assuming you've created your internal receive connector properly (locked down to Nagios IP) you need to run this command:

Get-ReceiveConnector RelayConnector | Add-ADPermission -User “NT AUTHORITY\ANONYMOUS LOGON” -ExtendedRights “ms-Exch-SMTP-Accept-Any-Recipient”

This will enable the specific permission that enables an open relay. This is disabled by default on all connectors created.

share|improve this answer
    
That worked like a charm. Thank you. –  Nic Young Sep 28 '11 at 17:53
    
You're welcome. –  Tatas Sep 29 '11 at 20:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.