Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Web server is IIS 7. Browsing by FQDN works fine. However, browsing by IP a login prompt appears. I saw this blog and I confirmed that Enable HTTP Keep Alive is checked. In IE if I add the IP address to the Local intranet sites then I can browse via IP address. So my question is - is there something else on IIS that needs to configured to allow browsing by IP? Or is this not IIS related?

share|improve this question
Can you post a screenshot of your bindings for the website in question? – Coding Gorilla Sep 28 '11 at 16:57
up vote 0 down vote accepted

This is IE related; it will automatically pass your Windows login credentials to pages that request authentication, if that page is hosted on a server in the Intranet zone (i.e. using the same DNS suffix as your machine.) Don't quote me on that but it's my understanding.

If all clients are in a domain and you require IP browsing, you can deploy a GPO that adds that IP to the Intranet zone. Otherwise work on your DNS infrastructure so that FQDN browsing will work.

Other browsers don't have this issue because they don't give out your Windows login credentials; some consider this a good thing :)

share|improve this answer

This is a feature of Internet Explorer Security.

Basically IE uses the logic that if the address requested contains periods and is not listed in the Local Intranet sites list, the site is relegated to the Internet zone which by default has the most restrictive security settings.


This behavior may occur if an FQDN or IP address contains periods. If an FQDN or IP address contains a period, Internet Explorer identifies the Web site or share as in the Internet zone.

In your case Windows Authentication wouldn't pass credentials to what it considers an Internet site, hence the prompt for credentials.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.