Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have virtualmin and settings on virtualhost: mailname and hosts mydomain.com

I have all my emails accounts on gmail e.g. support@mydomain.com

However when sending emails in Joomla (PHP Mail setting) I have in mail.log

 8BB689FE64: to=<support@mydomain.com>, relay=local, delay=0.05, delays=0.03/0/0/0.01, dsn=5.1.1, status=bounced (unknown user: "support")

It treats mydomain.com as local, this domain is on gmail.

When sending to other than mydomain.com it send fine.

share|improve this question

migrated from stackoverflow.com Sep 29 '11 at 9:54

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer

Try this:

1) Have a look in /etc/postfix for any mention of mydomain.com

2) Add the following line to /etc/postfix/transport

mydomain.com smtp:SERVER

where SERVER is the correct mail server (MX record) for your domain at gmail.com. You could try putting gmail.com, but I'm not sure. Have a look for the right answer using "host mydomain.com" or dig.

Then run:

postmap /etc/postfix/transport

Restart postfix and Bob's your uncle. Hopefully...

share|improve this answer
    
I had changed mydomain.com in main.cf but did not help as domain A points to my server –  miojamo Sep 20 '11 at 18:21
    
Did the transport stuff not help? –  ed. Sep 20 '11 at 18:26
    
nope still relay=local instead to google apps –  miojamo Sep 20 '11 at 18:39
    
OP fixed the issue: "I fixed the issue by not setting the mydestination param in main.cf." –  Jeff Atwood Sep 29 '11 at 9:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.