Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running MAMP Pro on my machine with all empty Postfix values. Yet, whenever my PHP application calls mail(), mail is being sent out from my machine. In a production environment this would be fine but I am in a development environment. how can i disable outbound mail in postfix? discusses setting the default_transport = error. However, this setting does not appear in /private/etc/postfix/main.cf, additionally, I cannot verify that this is infact what I need. I want to be absolutely sure that mail is disabled. I do want to be able to receive mail from my Entourage client but that's it.

Can anyone help? Many thanks!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Do it as described in the provided link. If the line is not present in main.cf then add a line with default_transport = error:This server sends mail only locally.

share|improve this answer
    
Thank you. Can you please explain what that means? "This server sends mail only locally"? I assume this means that I can send and retrieve mail only from and to myself but I want to be sure. –  syn4k Sep 29 '11 at 17:12
    
@Noor This is only the reply message. You could even write error:Ha ha. I don't like sending mail. Don't try again –  mailq Sep 29 '11 at 20:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.