Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a strange problem that I don't know how to diagnose:

I have a small test application that tries to make a socket connection to an RTU on port 5001 (can't change this). The application works without a problem in windows XP, but when I try to run it on windows 2008 the application fails to make the connection. The test application is a binary from a third party and I have no way to determine what it is trying to do.

The windows 2008 machine is part of a domain, and the windows XP machine that can succesfully use the program is not part of the domain (I don't know if this is relevant). The windows firewall is off, but I have also added incoming and outgoing communications in the firewall anyways. I created them for all ports 5000-6000 in and out on all networks (domain, private, public).

I realize I probably haven't provided much information here, but I don't normally deal with server issues like this, I am primarily a developer. If anyone has any advice about things I can check, it would be appreciated.

share|improve this question
    
It could be that the application isn't supported on W2K8. Have you tried running it in Compatibility mode? –  joeqwerty Sep 29 '11 at 17:37
    
can you do a simple telnet from the w2k8 -> rtu server on port 5001 –  tony roth Sep 29 '11 at 18:11
    
"telnet 10.131.0.251 5001" telnet doesn't seem to work. I issue that command and it looks like it just times out. I tried the program in compatibility mode for win xp SP3 and it also doesn't work. Thanks for the tips so far! –  kri Sep 29 '11 at 18:59
    
I actually just tried Telnet on the windows XP machine that can successfully run the test application and it can't telnet either, so I guess telnet doesn't tell me much. Just to add more information: both machines can ping the RTU. –  kri Sep 29 '11 at 19:05
    
are the w2k8 and the working xp workstation on the same subnet? –  tony roth Sep 29 '11 at 22:14

1 Answer 1

If the telnet isn't working from the Windows 2008 machine but it is from the XP machine then there is a firewall somewhere between the Windows 2008 machine and the target device that is blocking the connection.

End of Story.

share|improve this answer
    
Telnet doesn't work for either windows XP or windows 2008 as I mentioned. Both machines are on the 255.255.255.0 subnet. –  kri Sep 30 '11 at 14:34
    
Sorry, read your comment wrong the first time. Thought it said that telnet did work from the XP machine. On the XP machine can you connect via the app then do a netstat to see exactly what port and protocol the app is connected via? –  mrdenny Sep 30 '11 at 18:12
    
from netstat: TCP PT-920712:2070 10.131.0.251:5001 ESTABLISHED Thanks for taking the time to help! –  kri Sep 30 '11 at 19:45
    
If it makes a difference, I can't even seem to run "netstat" on the windows 2008 machine (The netstat above was on XP)... When netstat runs, its like it just hangs. It doesnt print any information about any current connections. I have verified that definitely windows firewall is off. –  kri Sep 30 '11 at 20:04
    
Try "netstat -n" to get rid of the name resolution. It's definetly TCP 5001. You should be able to telnet to it from the XP machine. Without being able to test, I'd recommend calling the 3rd party for tech support. –  mrdenny Sep 30 '11 at 21:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.