Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm tying to configure Apache for running phpmyadmin in it's own folder, using phpmyadmin.local server name. I'm not an Apache "guru" and i can't figure out why this is not working. Any help would be much appreciated. The error is: it's redirecting me on my ISP search page (like DNS not working).

hosts file:

127.0.0.1 localhost
127.0.0.1 phpmyadmin.local

httpd-vhosts.conf file:

<VirtualHost *:80>
    ServerName localhost
    DocumentRoot "C:/Users/Marco/Documents/www"

    <Directory "C:/Users/Marco/Documents/www">
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>

<VirtualHost *:80>
    ServerName phpmyadmin.local
    DocumentRoot "C:/Users/Marco/Documents/www/phpMyAdmin-3.4.5-english"

    <Directory "C:/Users/Marco/Documents/www/phpMyAdmin-3.4.5-english">
        DirectoryIndex index.php
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
</VirtualHost>
share|improve this question

migrated from stackoverflow.com Sep 30 '11 at 10:47

This question came from our site for professional and enthusiast programmers.

    
"Not working" is never a good error description. What exactly happens? What error messages do you get? –  Pekka 웃 Sep 29 '11 at 20:03
    
Do you have the NameVirtualHost setting in the main httpd.conf? –  davidethell Sep 29 '11 at 20:03
    
@davidethell no NameVirtualHost defined in httpd.conf! –  Gremo Sep 29 '11 at 20:08

1 Answer 1

up vote 0 down vote accepted

Before the virtualhost definitions put this line:

NameVirtualHosts *:80

When trying to access the URL from the browser be sure to type http:// before the url.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.