Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I uploaded a script called phpmotion to my vps, see this when you go to pretty much any page you'll see this error

Not Found

The requested URL /xyz was not found on this server.

Apache/2.2.3 (CentOS) Server at showpill.com Port 80

the .htaccess that they provide is there, everything is uploaded and installed correctly. the support team says that mod_rewrite is not enabled, but I checked and it is it enabled.

they told me to register on their forum to ask about it, I tried but it says: registration is currently disabled. Therefore I'm asking here, what would cause this problem?

EDIT

@George Tasioulis

LoadModule rewrite_module modules/mod_rewrite.so 

is not commented out, i changed AllowOverride to All created a .htaccess file as you said and still did not work

EDIT 2

the output of httpd -l

Compiled in modules:
  core.c
  prefork.c
  http_core.c
  mod_so.c

the output of apachectl configtest

Syntax OK
share|improve this question
    
Might want to look at upgrading your Apache. 2.2.3 was a good vintage, but it's pretty ancient at this point. –  Shane Madden Sep 30 '11 at 15:22
    
@Shane Madden - I have installed apache 2.2.21, which is the latest version but now i have another problem, first of all i wounder why am i seeing the apache test page when you go to showpill.com although my script and my index.php is still there....and then if you go to showpill/hi.php you see that apache doesn't seem to be working... –  user Oct 2 '11 at 14:58

2 Answers 2

up vote 1 down vote accepted

How did you check that mod_rewrite is enabled for sure?

I would say you try this: backup your current .htaccess file and create a new one with the following content:

Options +FollowSymLinks
  Redirect /google.html http://www.google.com

Now go an visit http://www.showpill.com/google.html and see if it redirects you to google.com If yes, then mod_rewrite works, if not check in your httpd.conf file that AllowOverride is set to All and restart Apache.

share|improve this answer
    
please read my edit sir –  user Sep 30 '11 at 11:36
    
Can you please tell what 'apachectl configtest' gives you? Also please post the output of 'httpd -l' –  George Tasioulis Sep 30 '11 at 12:44
    
please read my edit –  user Oct 1 '11 at 21:37
    
I found this forum post which has a guide on how to compile mod_rewrite without compiling apache from scratch. Maybe you should try that out. –  George Tasioulis Oct 18 '11 at 14:38
    
would you show it to me? –  user Oct 29 '11 at 8:29

created a .htaccess file as you said

Was there an .htaccess included with the install? Did you upload it to the server? Some FTP clients ignore dot files by default.

share|improve this answer
    
yes but i deleted the .htaccess to try what george said and i have write the name of the file right lol, i don't make these kind of mistakes anymore lol –  user Oct 1 '11 at 21:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.