Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Windows Server 2008 R2 with HyperV.

We have a virtual image dev environment running in the virtual machine, which comes under Microsoft's licensing; one real, and one virtual machine on Windows 2008 Standard Server.

However I can't find away to apply the licence to the virtual machine, if I enter the serial number it doesn't accept it, some mention is made of a licensing server but I can't find out much about that either. I'm not a Sysadmin, just a dev, being pelted with deadlines.

Although it is a virtual image it is a pain to have to reinstall it once a month.

So how can I make my virtual W2K8R2 accept the licence and work properly?

thanks Geoff

share|improve this question
    
FWIW You can run that server for many months (I've run them for well over 3 months) before it refuses to work anymore. It will complain a lot, but, at least in my experience they continue to function for well past the 30 day "limit". –  Coding Gorilla Sep 30 '11 at 14:46
    
I might be able to run for longer, but it doesn't feel right. Our desktops are occasionally audited for licence compliance. Since I am supposed to be able to run this under my MSDN licence it would scratching an itch, me and the others in my team, to "fix it". –  zeristor Sep 30 '11 at 15:26
add comment

1 Answer

It sounds like you might be applying the wrong product key. You might want to review your licenses and make sure you've got the right keys.

share|improve this answer
    
I am using the licence supplied by MSDN, and since the W2k8 licence enables the server, and a single virtual OS I would have thought it would work. –  zeristor Sep 30 '11 at 15:23
1  
Well,noly if ythe virtual server can connect to MS and you ahve activations left. –  TomTom Sep 30 '11 at 15:27
    
Looking at my action pack I've got physical and virtual keys for all of my server 2008 r2 licenses. Maybe check with the administrator of your MSDN account and verify that you dont have something similar? –  ErnieTheGeek Sep 30 '11 at 15:30
    
Thanks Ernie. I have an online MSDN subscription, I can't find any mention of a Virtual key, but it is a clue towards a solution. –  zeristor Sep 30 '11 at 15:51
    
A call to your microsoft rep might be in order. –  ErnieTheGeek Sep 30 '11 at 17:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.