Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Dell PowerEdge T310 server with a single serial port running Windows Server 2008 R2 Enterprise. I have a USRobotics 56k external modem connected to the serial port. The modem talks to a gate access control system. The gate access database is on the server.

I first verified in the Server's BIOS that the serial ports are enabled and that port 1 is assigned serial port 1 and port 2 is assigned to serial port 2 without console redirection. I used the control panel to access "Phones & Modems" and then added a "Standard 56k Modem" to COM1. I right clicked "properties" and then selected the "Diagnostics" tab. I then clicked "Query Modem" and got an error message saying The modem failed to respond.

I went into "Device Manager" and verified that COM1 port is ok. I also verified that the baud rate, bits/byte, and parity were correctly set. The device manager said that COM1 was working correctly. I even tried to install the USRobotics drivers but they would not load because the driver load utility first goes out to see if server can talk to the modem. Of course the modem is powered on and the cable is connected to serial port 1 (there is only one serial port).

The USRobotics driver compatibility page says that the drivers are compatible with windows Server 2008 R2. Any ideas?

share|improve this question
    
Tried a terminal program (eg PuTTY), connect to the comm port, try entering "AT" and see if it reponds? Sure you have the right cable (a straight through serial cable, not a UPS cable, not a null-modem cable)? –  Chris S Sep 30 '11 at 19:50

1 Answer 1

up vote 4 down vote accepted

A modem connected to a serial port should be detected by PnP. My advice would be to uninstall the modem you "installed" and invoke Windows to search for new hardware in Device Manager. If Windows is able to find the modem it will install the appropriate driver, if it has one for that modem.

If this doesn't work then my suggestion would be to purchase a USB to Serial adapter to connect the modem to the server (you may need a different modem as well).

I've done this before and not had any problems (this is what I use at home as my last ditch internet connection in case my cable internet goes down).

share|improve this answer
    
My BAD...I checked the cable and discovered that it is a null modem cable. I cannot answer my own question for 8 hours becouse I don't have enough ServerFault points so please no more answers required. I need to get a new cable. Thanks Chris S & joeqwerty. –  user871962 Sep 30 '11 at 19:57
    
Glad to help... –  joeqwerty Sep 30 '11 at 20:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.