Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Using SSRS in integrated mode, Reports can be viewed in IE but not in Firefox, Chrome, Safari, etc. They get "An unexpected error occurred while connecting to the report server. Verify that the report server is available and configured for SharePoint integrated mode." (Oh, and it also happens to one IE user on the domain as well)

It might be a double hop issue, since we do have a dual farm (frontend and report server). I've been following directions pertaining to double hop authentication, and I'm currently using setspn, all to no avail. I cannot find anyone else with this problem. This is really frustrating.

share|improve this question
    
Thanks but that does not seem to work. Our network is named local.mycompany.com and I tried that, and mycompany.com and even the IP address of the Report Server. The error comes back very fast and I cannot find any log messages anywhere. –  David Sep 30 '11 at 20:51
    
Chris, wait, I did a variation on your comment and it works! I set "network.negotiate-auth.trusted-uris" AND "network.negotiate-auth.delegation-uris". I set them both to our web application name which is "intranet";. You should make this into your answer so I can accept it. This is great, I've been trying to get this working for over a month, thanks! –  David Sep 30 '11 at 21:11
add comment

2 Answers 2

up vote 1 down vote accepted

Firefox by default has NTLM and Kerberos authentication disabled. Websites smart enough to detect this give an appropriate error page. SharePoint isn't that smart.

Enable Negotiated authentication by opening "about:config", search for "network.negotiate-auth.trusted-uris" and set it to the domain name your SP server is in (ie if your SP server is sp.example.com, set the value to example.com). You may need to se the "network.negotiate-auth.delegation-uris" too, depending on your configuration.

share|improve this answer
add comment

Sharepoint requires ActiveX for variety of it's features to function properly. While I don't have experience with integrated mode, I know that using browsers aside from IE will limit your Sharepoint capabilities.

It would also help if you described your network setup (Sharepoint version, etc) to help with troubleshooting.

share|improve this answer
    
I've got SSRS reports in our company SP2010 site open right now. They look identical to viewing them in IE. While SP might have some ActiveX in it still, it's not terribly common to run across. –  Chris S Sep 30 '11 at 19:59
    
We are using WSS 3.0 version 12.0.0.6548, with the Frontend web server on Essential Business Server 2008, and the other Sharepoint server is Windows Server 2003 with Reporting Services and SQL Server 2008 standard. I doubt it is an ActiveX issue since this also happens on an one IE browser as well, which I reset to defaults, but I will double check. We are not using any special webparts or anything. –  David Sep 30 '11 at 20:18
    
In addition, the Reporting Services Authentication Mode in Central Administration is set to Windows Authentication. In rsreportserver.config the Authentication section is as follows: <AuthenticationTypes> <RSWindowsNTLM/> <RSWindowsNegotiate/> </AuthenticationTypes> –  David Sep 30 '11 at 20:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.