Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have configured VPN in windows 2008 server. Two NIC one public and a loopback adapter with private IP 192.168.2.200.

We can connect via VPN for any users in system and can check the shares \192.168.2.200, however If we try to connect drive \192.168.2.200\c$ for any users other than administrator it gives 'Logon unsuccessful' message. Only administrator can connect.

Now we have shared the C drive to gain access to files for the users connecting to system. I have checked with Firewall and other network and share settings in the server which is fine.

Any idea will be highly appreciated!.

share|improve this question
2  
I bet you that you can't access C$ even within you network. Without VPN involved. –  mailq Sep 30 '11 at 21:03
    
I could not get you exactly. Can you add more clarity on the above statement. If I am doing anything wrong let me know. –  Riyas Sep 30 '11 at 21:09
2  
C$ is an administrative share. Only administrators are allowed to access. This is by design. –  mailq Sep 30 '11 at 21:24
3  
I don't see any reason to down vote. I think this post provides valuable learning lessons to anyone who may unknowingly be attempting the same thing. Was the downvote a point to say the author is not as smart as you or do you not see any value in this post at all? –  Safado Sep 30 '11 at 21:46
    
Thanks for your suggestions. It has been fixed finally. The problem is due to UAC settings where by default the access is restricted even though you are in administrator group. I have enabled two policy settings in UAC and finally the access are granted for the users. –  Riyas Oct 5 '11 at 11:47

1 Answer 1

Thats how its supposed to be. Shares with a $ after it are administrative shares and thus you have to be an administrator to get to it.

Edit: After verifying pauskas comment it would appear that only the default shares like that are administrator equivalent only.

share|improve this answer
3  
Not correct - you can create shares with $ signs to hide it but allow access for any user. It's just the default administrative shares that are administrator-only. –  pauska Sep 30 '11 at 21:33
2  
Well hell, you learn something new every day. –  ErnieTheGeek Sep 30 '11 at 21:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.