Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to configure my subversion server using apache2, mod_dav_svn and a basically digest authenticaton (for now). I've setup the subdomain svn.example.com to serve the repos and created the virtualhost conf like this:

<VirtualHost *:80>
    ServerAdmin admin@example.com
    ServerName svn.example.com

    <Location />
            DAV svn

            # Automatically map any "/foo" URL to repository /var/svn/repos/foo
            SVNParentPath /var/svn/repos

            # List repositories if viewed from a web browser
            SVNListParentPath on

            # Authentication: Digest
            AuthName "Private Area"
            AuthType Digest
            AuthUserFile /etc/svn-auth.htdigest

            # Authoriztion: Authenticated users only
            Require valid-user
    </Location>
</VirtualHost>

This conf file (svn.example.com) resides inside apache2's sites-available directory, as well inside sites-enabled.

The last thing, I created the auth user file using htdigest.

At this step I wanted to test the setup. But each time I open svn.example.com in a browser all I get is a blank page. I don't know what is wrong. I checked the apache access/error log files, but there's nothing there that could help.

Any thoughts ?

share|improve this question

2 Answers 2

I bet there must be something in the error_log. Make sure that Apache has access permission on the SVN root directory:

# chown -R www-data:www-data /var/svn/repos
share|improve this answer
    
I already chowned the repos directory with that user/group. In error_log there are only notices from when I restarted apache. Nothing else. –  misterjinx Oct 1 '11 at 18:01
    
Test Apache syntax apachectl configtest, set LogLevel to debug and add a ErrorLog directive for your virtual host, reproduce this problem to see if you have something in log file. –  quanta Oct 2 '11 at 1:43
    
configtest says Syntax is OK. I added debug LogLevel and ErrorLog and the only lines in error.log are [notice] caught SIGTERM, shutting down and [notice] Apache/2.2.16 (Ubuntu) DAV/2 SVN/1.6.12 configured -- resuming normal operations. If it matters, I commented the lines with authentication and authorization but nothing changed :|. I don't know, could be something with apache ? It's a fresh install, maybe I forgot to configure something properly. ` –  misterjinx Oct 2 '11 at 5:46
up vote 0 down vote accepted

I figured out what it was. First of all I had an error in my file zone, instead of a CNAME entry for the subdomain, there was an A record.

After that, I enabled the auth_digest module and everything is working fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.