Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting the output of "pcretest -C"

 UTF-8 support
  **No Unicode properties support**
  Newline character is LF
  Internal link size = 2
  POSIX malloc threshold = 10
  Default match limit = 10000000
  Default recursion depth limit = 10000000
  Match recursion uses stack

I need to turn "Unicode properties support" on.

I tried with this(http://chrisjean.com/2009/01/31/unicode-support-on-centos-52-with-php-and-pcre/) solution but while upgrading, getting conflicts with current PCRE and while installing newly showing dependency error.

Asking for another packages,when I tried to install (pcre-devel-6.61.fc5.remi.i386.rpm)devel packages,unfortunately getting

warning: pcre-devel-6.6-1.fc5.remi.i386.rpm: Header V3 DSA signature: NOKEY, key ID 00f97f56
error: Failed dependencies:
    pcre = 6.6-1.fc5.remi is needed by pcre-devel-6.6-1.fc5.remi.i386

What to do to make this settings up. Thanks advance.

share|improve this question
    
You're installing a Fedora Core 5 package onto a EL5 system? –  Ignacio Vazquez-Abrams Oct 2 '11 at 8:03
    
I followed this artcile chrisjean.com/2009/01/31/… –  mushfiq Oct 2 '11 at 8:23
1  
Have you actually read the article you linked to? –  Ignacio Vazquez-Abrams Oct 2 '11 at 8:30
    
@IgnacioVazquez-Abrams if caveman is missing something, could you please help him out? –  rubayeet Oct 2 '11 at 10:29
    
Please tell us the exactly step you did to cause the above error. –  quanta Oct 2 '11 at 12:26

1 Answer 1

up vote 0 down vote accepted

Assuming you did following the steps you refer, do a reinstall of the package referenced in here (not the FC version), but instead of an upgrade, use:

rpm -ivh --replacepkgs pcre-6.6-2.7.x86_64.rpm

This will allow you to replace the packages that already exist on the system, since it is same version, but with different options enabled.

share|improve this answer
    
It works!to solve it had to rebuild the package with changed conf and installing it :) –  mushfiq Oct 10 '11 at 3:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.