Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running cacti-0.8.7d on a Fedora 10 host
the php version we're using is

/usr/share/cacti/scripts $php -v PHP 5.2.6 (cli) (built: May 8 2008 10:23:54)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies

I've been trying to use several templates from different sources (MySQL templates, etc ...), and when importing any of them, cacti will eat brackets (properly specified as < and > in the XML template file).

Every Input Methods in the template end up being massacred:

<path_php_binary> -q <path_cacti>/scripts/ss_get_by_ssh.php --host <hostname> --type memcached --items bh,bi --server <server>

becomes

path_php_binary -q path_cacti/scripts/ss_get_by_ssh.php --host hostname --type memcached --items bh,bi --server server

which doesn't work when called by cacti, as it cannot even find the path to the script.

I've been looking into the cacti forum, and found some messages which seem related to that one, and some patches provided which don't apply to my version of cacti.

With the number of input methods i would have to change manually, I ended up doing nasty things such as direclty updating the cacti database to replace the parameter names with proper brackets, but sometimes the command line end up totally munged ...

Anyway, have you ever come across this problem with cacti ? did you find a proper way to fix it ? i'm suspecting that this could come from my version of PHP, and I found out that any kind of PHP code really hurts my eyes :-)

This is my 1st question on serverfault, so please be indulgent ...

share|improve this question
    
Haven't run into this, but it sounds like a magic_quotes issue... in /etc/php.ini, what are your magic_quotes_gpc and magic_quotes_runtime variables set to? –  gharper Jun 25 '09 at 20:35
    
Those as the current value: ` ; Magic quotes for incoming GET/POST/Cookie data. magic_quotes_gpc = Off ; Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc. magic_quotes_runtime = Off ` –  zuzur Jun 26 '09 at 10:30

1 Answer 1

In their FAQ I found out about issue 49 seems to have a workaround.

share|improve this answer
    
Yes this is the workaround I discussed in my question (I made the comment in the forum, and Vadim added it to the faq ...), but couldn't add a link to it to my question (because of ServerFault's limitation of 1 link in questions for young padawans such as myself). As i said, it doesn't really fix the problem, as it has to be updated for every script parameter. I'd like to find a more generic way of fixing this ... –  zuzur Jun 25 '09 at 20:21
    
oops guess I should have looked a little closer –  Adam Jun 26 '09 at 13:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.