Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently upgraded my laptop from WinXP Pro (32-bit) to Windows 7 RC (64-bit). I have a number of VirtualPC 2007 images that I use for testing on various platforms and looking at beta software. I have installed the 64-bit version of VirtualPC. The images all work with the exception of the mouse wheel within the virtual machine. I have tried this out with WinXP Pro, Windows 7 RC, and Windows Server 2008 images. All are 32-bit and all exhibit the same behavior: a gentle rotation of the wheel does nothing; a quick rotation of the wheel sometimes gets a scroll and sometimes not. I regard this behavior as unusable as I tend to use the mouse wheel a lot. All of this worked just fine on WinXP. I have re-installed the Virtual machine additions on all of the machines. The Windows 7 RC virtual image was created after the upgrade to Windows 7 and the 64-bit version of VirtualPC (just to isolate the possibility that I had corrupted the images during the transition).

I have googled, binged, and yahoo-ed. There are scattered mentions of this problem (dating back to VPC 2004) but no solutions.

I am aware that I could start up one of these images and then use remote desktop connections to get access to that image. I, in fact, do just that for some development that I am doing; the mouse works just fine. This is acceptable in this case because I spend hours at a time in the development VM. These test environments are different in that I will bring up an image for just a short time: minutes rather than hours. Adding the rdc step is much more significant in these cases.

Does anyone have any idea of what to do next?

share|improve this question
The Win7 RC is no longer available, supported, or recommended. – Chris S Jul 1 '10 at 15:09

Well windows 7RC is just an RC, after all. You can't reasonably expect that everything just works.

share|improve this answer

It is a little confusing reading your post (always is with new releases of MS products).

Are you running "Windows Virtual PC" on your new workstation, and not "Virtual PC 2007"?

share|improve this answer
+1 Virtual PC 2007 is not support in Win7, he needs the Win7 version to start. Also using the Win7 RC isn't helping. – Chris S Jul 1 '10 at 15:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.