Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

hi i have a problem with a 9.04 server deploy, i have two nics and both are now not visible after the server had been off for a month. the client had turned it off as they were moving and now when we boot up the nics are not seen under an ifconfig command, only the lo is listed.

i will have to check on monday to see wheter a sudo lshw -class network will show the nics as being there from a hardware perspective.

i do know the following:

  • working prior to turning it off
  • we had inet static for our ifaces file so they were hard coded to the ip's
  • restarting the unit did not make a difference
  • leds on the nic light up when an ethernet cable is plugged into it and then into a switch

we have not tried doing an ifconfig eth0 or eth1 up command yet, i have to wait for the client to get back onsite so that i can walk him through doing this over the phone.

does anyone have any idea why all of a sudden the nics, they are both intel based gig e ethernet, would just not show up anymore with their respective ip address based on the ifaces file? we did verify that the ifaces file has not changed, so i don't think it is anything with that.

thanks.

share|improve this question
1  
Try reseatting the card? It could be a physical issue. –  Zoredache Oct 2 '11 at 18:56
    
Zoredache, you know we never tried that since i was on the phone trying to help out but yes i will have them reseat them and then update this post.gd –  dasko Oct 2 '11 at 18:58
    
ok the nics are seated properly and no other issues. with a live 10.04 cd the two nics are seen so there is something on my config that is not showing eth0 and eth1 any more suggestions? thanks –  dasko Oct 6 '11 at 15:48
    
lshw -class network lists the two nics but says DISABLED –  dasko Oct 6 '11 at 15:53
2  
Ah, you may want to modify /etc/udev/rules.d/70-persistent-net.rules if you want to fix the device names. –  Zoredache Oct 6 '11 at 16:45

1 Answer 1

up vote 3 down vote accepted

After moving equipment one thing that you should check that your card is properly seated.

ifconfig -a showed eth2 eth3 and eth4, it seems something happend to eth0 and eth1, when i did a dhclient on eth3 it came up.

On a Debian/Ubuntu system the interface naming is controlled by /etc/udev/rules.d/70-persistent-net.rules. Feel free to go in and edit that file so that the correct device is given the names that you want.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.