Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm just starting the migration from Exchange 2003 to Exchange 2007. Almost immediately I stumbled across this problem. I have performed the ForestPrep and DomainPrep and started installing the Hub Transport Role.

During the prerequisite check it give me the following warning:

Warning: Setup cannot detect an SMTP or Send connector with an address space of '*'. Mail flow to the internet may not work properly.

Needless to say I want my mail flow to the internet to work properly...

share|improve this question

1 Answer 1

up vote 3 down vote accepted

The setup is warning you that it can't find a connector that is setup for a wildcard SMTP address. Looking at your current Exchange 2003 setup, do you have an SMTP connector? If so, what address-space is assigned to it? A stock SMTP connector would have an address space of "*" assigned.

It may be that you're running w/o an SMTP connector and just using the stock behaviour of the "Default SMTP Virtual Server" to deliver mail to the Internet. If you're just a single-server Exchange 2003 environment that may be the case. If it is, I'd continue with the Exchange 2007 installation and immediately create an SMTP send connector after the install completes. See: http://technet.microsoft.com/en-us/library/aa997285.aspx

If the above applies (re: single Exchange 2003 server w/ no SMTP connector), be aware that you will have to "undo" any smart host settings that you might've applied directly to the Defualt SMTP Virtual Server. It's best if you try and return these settings to stock and place such settings on the new E2K7 SMTP send connector. (In a pure E2K3 environment, it's preferrable to create an SMTP connector and apply such settings there, but I've seen a lot of E2K3 single-server environments where settings were set directly on the Default SMTP Virtual Server. It normally comes back to bite people when they add a 2nd Exchange Server computer or when they upgrade to E2K7.)


Edit:

By creating an SMTP Send Connector on the E2K7 side after the install completes, email bound to the Internet from the E2K3 server will deliver to the E2K7 server first, then be relayed to the Internet. Email sourcing on the E2K7 side bound for the Internet will deliver directly there. Be sure your firewall will let the E2K7 machine source connections to the Internet, TCP ort 25. (Your firewall should be configured to drop outgoing TCP connections to port 25 EXCEPT from authorized mail servers.)

As you move mailboxes off of the E2K3 machine and retire it, Internet mail flow will continue. It doesn't matter, initially, if your inbound mail continues to come to the E2K3 machine, but you'll want to change that over to the E2K7 machine as you get closer to retirement of the E2K3 machine.

Be sure to work thru the retirement procedures from Microsoft, and you'll have no problems. There's some work in replicating off the public folder hierarchy and getting all of the E2K3 infrastructure cleaned up, but it's quite feasible to end up with a clean and properly functional infrastructure when all is said and done. (I've done several mid-sized E2K3 to E2K7 migrations, and they go fine so long as you move methodically and with care.)

share|improve this answer
    
"Default SMTP Virtual Server" is listed in our SMTP connectors. Should I create a "default" connector? Or will the "Default SMTP Virtual Server" continue to work for passing mail in the Exchange 2007 environment. –  TrueDuality Jun 25 '09 at 18:56
    
You're seeing "Default Virtual Server" listed as a CONNECTOR? That doesn't make sense. I'd expect that you're seeing it under "Protocols / SMTP", but not under "Connectors". (It's possible, but unlikely.) You're going to want to create an SMTP Send Connector on the new Exchange 2007 server computer after the E2K7 install is complete. That's the best possible configuration, long-term. –  Evan Anderson Jun 25 '09 at 19:00
    
Err thats what I meant, been staring at the System Manager too long >.< –  TrueDuality Jun 25 '09 at 19:01
    
It is listed under Protocols / SMTP not in the connectors list –  TrueDuality Jun 25 '09 at 19:02
    
That's what I suspected. You're not using a connector because you were just relying on the stock behaviour of the Default SMTP Virtual Server. You're in good shape. Continue with the install and create an SMTP send connector on the E2K7 side and you'll be fine. (Check my edit above for more notes.) –  Evan Anderson Jun 25 '09 at 19:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.