Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Since the last days, all my subdomains doesn't work anymore. I get only an 404 Error/Placeholder page. I have not make any changes on my Lighttpd.conf or on the 10-simple-vhost.conf.

Does have anyone similar problems? How can i fix that?

Here is my lighttpd.conf

server.modules = (
    "mod_access",
    "mod_alias",
    "mod_compress",
    "mod_redirect",
    "mod_rewrite",
)

server.document-root        = "/var/www/hosts"
server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
server.errorlog             = "/var/log/lighttpd/error.log"
server.pid-file             = "/var/run/lighttpd.pid"
server.username             = "www-data"
server.groupname            = "www-data"

index-file.names            = ( "index.php", "index.html",
                                "index.htm", "default.htm",
                               " index.lighttpd.html" )

url.access-deny             = ( "~", ".inc" )

static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

include_shell "/usr/share/lighttpd/use-ipv6.pl"

dir-listing.encoding        = "utf-8"
server.dir-listing          = "enable"

compress.cache-dir          = "/var/cache/lighttpd/compress/"
compress.filetype           = ( "application/x-javascript", "text/css", "text/html", "text/plain" )

include_shell "/usr/share/lighttpd/create-mime.assign.pl"
include_shell "/usr/share/lighttpd/include-conf-enabled.pl"

$HTTP["host"] =~ "^www\.(.*)$" {
  url.redirect = ( "^/(.*)" => "http://%1/$1" )
}

$HTTP["host"] =~ "^(www\.)?cake-up\.de$" {
        url.redirect = ("^/(.*)" => "http://www.example.com/$1")
}

$HTTP["host"] =~ "^(www\.)mail.cakeup\.de$" {
        url.redirect = ("^/(.*)" => "http://mail.example.com/webmail")
}  

And here is an example of one of my Subdomains

$HTTP["host"] == "stage.example.come" {
    # block 1
    server.name = "stage.example.com"
    var.user = "fwirths"
    var.hostdir = "/var/www/hosts/stage.example.com/"
    server.document-root = "/var/www/hosts/stage.example.com/www"
    var.logdir = "/var/www/hosts/stage.example.com/logs/"
    accesslog.filename = "/var/www/hosts/stage.example.com/logs/access.log"
    server.errorlog = "/var/log/lighttpd/error.log"
    server.follow-symlink = "enable"
    server.dir-listing = "disable"
    fastcgi.server           = (
        ".php" => (
            (
                "bin-path"              => "/usr/bin/php5-cgi",
                "socket"                => "/tmp/php.socket",
            ),
        ),
    )
    server.error-handler-404 = "/index.php"
    index-file.names = ("index.php", "index.html")
} # end of $HTTP["host"] == "stage.example.com"
share|improve this question
    
Shouldn't $HTTP["host"] == "stage.example.come" { be $HTTP["host"] == "stage.example.com" {? –  Shane Madden Oct 3 '11 at 16:42
    
Its only a tipping error. Its in my Config correct. So that isnt the Solution :/ –  hazelnut Oct 4 '11 at 11:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.