Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm running Apache HTTP Server 2.2 on a Windows 2008 box. But for some reason, I can only get the site to load locally.

The box is assigned 3 IP addresses. I already configured IIS to listen to the first 2 IPs and assigned Apache the third by specifying 'Listen 209.67.xxx.xx:80' in the httpd.conf file. I think it was a pretty standard installation and that is the only thing I changed.

I then bring up the browser in server and type in the IP. The default page with "It works!" appears. Great! But when I try to hit that page from another machine from outside, it takes a few seconds and then just loads an empty page. Nothing in the page html source either.

I know it's not a firewall issue because IIS is able to serve up pages all day. It's not something with that IP because when I tell IIS to listen to that IP, it works.

One other odd thing, when I 'telnet 209.67.xxx.xx 80' it seems to connect fine. Then I do a 'get' and it's the same thing as the browser...thinks for a few seconds, then returns nothing.

I've gotten this setup to work in another environment a few weeks ago but we migrated to a new data center and now it's not working. Not sure what else to do here. Is it an Apache configuration I'm missing? Please help!

Thanks!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Set LogLevel debug and look what is happening in access and error logs. Note, that VirtualHOsts may have their own LogLevel settings - change them too.

Try to completely disable firewall for testing: IIS is working OK, but firewall may have special rules for different programs.

Copy apache with all configs to win2003/winxp machine and look, if it works there. You will see, if this bug is in apache configuration or somewhere in OS settings.

share|improve this answer
    
Well I feel silly. Indeed it was the Windows firewall that was blocking it. I checked the network firewall but didn't have the sense to check the local firewall. I added Apache to the list of allowed programs and now it's running just fine. Thanks. –  nthpixel Oct 4 '11 at 0:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.