Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to get my xen-sources compiled and I'm having mixed results depending on which version I use. So far I haven't got any of the currently available (as of a week or so ago) xen-sources working through gentoo's portage.

When I try to make menuconfig for 2.6.18-xen-r12 I get:

Makefile:410: *** mixed implicit and normal rules.  Stop. 

When I try to use 2.6.34-xen-r3, the kernel boots but it gets caught on what I think is a USB issue, but I can't get the exact log as the booting never completes.

When I try to use 2.6.34-xen-r4, it seems to not work with my SCSI controller (unsure if I'm doing something wrong, but I'm pretty sure I'm not) and in turn it can't find any disks.

When I try to make && make modules_install for version 2.6.38-xen it fails at:

 LD      drivers/xen/sfc_netutil/sfc_netutil.o
  LD      drivers/xen/sfc_netutil/built-in.o
  LD      drivers/xen/built-in.o
drivers/xen/blktap2-new/built-in.o: In function blktap_ring_init':
(.init.text+0xe0): multiple definition ofblktap_ring_init'
drivers/xen/blktap2/built-in.o:(.init.text+0x8c): first defined here
drivers/xen/blktap2-new/built-in.o: In function blktap_ring_destroy':
(.text+0x334): multiple definition ofblktap_ring_destroy'
drivers/xen/blktap2/built-in.o:(.text+0xcdd): first defined here
drivers/xen/blktap2-new/built-in.o: In function blktap_device_init':
(.init.text+0x16e): multiple definition ofblktap_device_init'
drivers/xen/blktap2/built-in.o:(.init.text+0x122): first defined here
drivers/xen/blktap2-new/built-in.o: In function blktap_ring_kick_user':
(.text+0x88e): multiple definition ofblktap_ring_kick_user'
drivers/xen/blktap2/built-in.o:(.text+0x5df): first defined here
drivers/xen/blktap2-new/built-in.o:(.bss+0x0): multiple definition of blktaps'
drivers/xen/blktap2/built-in.o:(.bss+0x0): first defined here
ld: Warning: size of symbolblktaps' changed from 1024 in drivers/xen/blktap2/built-in.o to 4 in drivers/xen/blktap2-new/built-in.o
drivers/xen/blktap2-new/built-in.o: In function blktap_device_destroy':
(.text+0x105d): multiple definition ofblktap_device_destroy'
drivers/xen/blktap2/built-in.o:(.text+0x2b9b): first defined here
drivers/xen/blktap2-new/built-in.o: In function blktap_request_free':
(.text+0x15de): multiple definition ofblktap_request_free'
drivers/xen/blktap2/built-in.o:(.text+0x346c): first defined here
drivers/xen/blktap2-new/built-in.o: In function blktap_device_create':
(.text+0xd70): multiple definition ofblktap_device_create'
drivers/xen/blktap2/built-in.o:(.text+0x180f): first defined here
drivers/xen/blktap2-new/built-in.o:(.data+0xac): multiple definition of blktap_debug_level'
drivers/xen/blktap2/built-in.o:(.data+0x48): first defined here
drivers/xen/blktap2-new/built-in.o: In functionblktap_ring_create':
(.text+0x863): multiple definition of blktap_ring_create'
drivers/xen/blktap2/built-in.o:(.text+0xd2b): first defined here
drivers/xen/blktap2-new/built-in.o: In functionblktap_sysfs_destroy':
(.text+0x193d): multiple definition of blktap_sysfs_destroy'
drivers/xen/blktap2/built-in.o:(.text+0x365f): first defined here
drivers/xen/blktap2-new/built-in.o: In functionblktap_sysfs_init':
(.init.text+0x261): multiple definition of blktap_sysfs_init'
drivers/xen/blktap2/built-in.o:(.init.text+0x20a): first defined here
drivers/xen/blktap2-new/built-in.o: In functionblktap_sysfs_create':
(.text+0x1987): multiple definition of `blktap_sysfs_create'
drivers/xen/blktap2/built-in.o:(.text+0x3bc3): first defined here
make[2]: * [drivers/xen/built-in.o] Error 1
make[1]:  [drivers/xen] Error 2
make: ** [drivers] Error 2

So far as I can tell every version available to me fails to work, and I'm unsure why.

This is on some IBM x330's, and I'm having the same issue on a DL380 G3. I tried posting about this on the gentoo forums, and so far nobody has said anything on the matter.

share|improve this question

1 Answer 1

I haven't been a Gentoo user in about 5 years, and I'm not sure exactly why you're getting those build errors. Have you tried just using Linux 3.0? Xen dom0 support has been upstreamed into mainline Linux since version 3.0, and you may have better luck compiling that kernel than the older ones you've been trying to compile.

share|improve this answer
    
I tried 3.0.4 and it doesn't seem to have the hooks I need (I could be wrong). I was following this guide FYI: gentoo.org/doc/en/xen-guide.xml –  BloodyIron Oct 4 '11 at 19:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.