Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When trying to dismount an encrypted partition i get the ol' Error: device-mapper: remove ioctl failed: Device or resource busy. The recommended solution from the interwebz seems to be to change some truecrypt settings to not use kernel cryptographic services.

This would be easy to try, if it weren't for the fact that the system has precisely no window managers installed.

Is there a way to change the truecrypt setting "Do not use kernel cryptographic services" from the terminal?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

According to truecrypt -h:

-m, --mount-options=OPTION1[,OPTION2,OPTION3,...]
 Specifies comma-separated mount options for a TrueCrypt volume:
  headerbak: Use backup headers when mounting a volume.
  nokernelcrypto: Do not use kernel cryptographic services.
  readonly|ro: Mount volume as read-only.
  system: Mount partition using system encryption.
  timestamp|ts: Do not restore host-file modification timestamp when a volume
   is dismounted (note that the operating system under certain circumstances
   does not alter host-file timestamps, which may be mistakenly interpreted
   to mean that this option does not work).
 See also option --fs-options.

So, try this:

truecrypt -t -m=nokernelcrypto volume mountpoint
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.