Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I get this error message while trying to access this site in firefox.

The site is hosted on a dedibox with Debian, apache2, php5, and bind9.

If run a dig command, or any kind of ping i get the good IP, so the hostname is actually resolved. It's just that it doesn't work in the browser.

I put a test script in the document root, and tried to access it directly but it's the same, so no application problem.

I put the ip in my hosts file on windows and try to access the site again. It worked! So actually there is some kind of dns infinite loop or something like that, that is correctly bypassed by ping or dig, but not by the browser (how strange is that?)

I took the control of this server late in development, so i don't know if the bind daemon on the server is actually the one who should resolve the domain, or someone else, and for that matter nobody knows know, i need to find out. There were some entries for the domain in named.conf file, and i removed them and also asked the client to set other nameserver that should resolve the domain.

I don't have experience with dns. Does anyone have any suggestions of what can i do more to identify the problem ?

UPDATE: so far, i found there is a problem with networking. I did a /etc/init.d/networking restart through ssh and now the server seems to be down. I mean all interfaces are down and i can't connect. The server is not accessible by me. What could be wrong now ?

share|improve this question
    
I'm not looking for an actual answer solution, any kind of research that i can do to identify the problem could help. So if you have anything in mind please tell me. –  Dan Bizdadea Oct 4 '11 at 8:45
    
I can't even contact the server's IP address, neither via ping nor http. –  Sven Oct 4 '11 at 8:48
    
really? wait... –  Dan Bizdadea Oct 4 '11 at 8:50
    
I updated my question, it resolved correctly from here... Ping indeed does not respond, but still the ip is resolved. I have other sites on that server and they all work. –  Dan Bizdadea Oct 4 '11 at 8:52

3 Answers 3

up vote 2 down vote accepted

So, the domain resolves to:

Non-authoritative answer:
Name:    rencontres-selection.com
Address:  88.191.110.117

So, DNS seems fine. However, I'm unable to hit it on port 80:

telnet 88.191.110.117 80
Connecting To 88.191.110.117...Could not open connection to the host, on port 80: Connect failed

Ping also doesn't work:

Pinging 88.191.110.117 with 32 bytes of data:
Request timed out.
Request timed out.
Reply from 57.211.69.173: Destination net unreachable.
Reply from 57.211.69.173: Destination net unreachable.

Ping statistics for 88.191.110.117:
    Packets: Sent = 4, Received = 2, Lost = 2 (50% loss),

tracert tells me this:

Tracing route to 88-191-110-117.rev.dedibox.fr [88.191.110.117]
over a maximum of 30 hops:

  1    <1 ms     4 ms    <1 ms  10.95.133.1
  2     1 ms    <1 ms     1 ms  172.21.100.2
  3     9 ms     1 ms     7 ms  10.95.135.249
  4     2 ms     3 ms     9 ms  57.211.69.173
  5     *     57.211.69.173  reports: Destination net unreachable.

Trace complete.

So, I'm thinking there is something wrong with the router in one of the final hops. It has no idea where to go next to give you access to the server.

share|improve this answer
    
other sites hosted on that domain work just fine on 80 + ping + everything. only this one does not. –  Dan Bizdadea Oct 4 '11 at 9:30
    
Do these domains all have the same IP? –  Bart De Vos Oct 4 '11 at 9:34
    
Some of them, yes, other no. –  Dan Bizdadea Oct 4 '11 at 9:36
    
Are there other domains hosted on 88.191.110.117? –  Bart De Vos Oct 4 '11 at 9:37
    
Yes, there are more than 2 other domains hosted on that ip, they work. By i think they are resolved by other nameserver not the one installed at 88.191.110.117 –  Dan Bizdadea Oct 4 '11 at 9:50

You can discover the correct nameservers for a domain using "whois", for example:

  whois rencontres-selection.com

However that shows no results. So we fall-back to:

skx@birthday:~$ dig -t ns rencontres-selection.com +short
sd-18368.dedibox.fr.
nssec.dedibox.fr.

So does that work?

skx@birthday:~$ dig -t a rencontres-selection.com +short @sd-18368.dedibox.fr
88.191.110.117
skx@birthday:~$ dig -t a rencontres-selection.com +short @nssec.dedibox.fr
88.191.110.117

Now we can see that .117 is the host to contact:

skx@birthday:~$ echo -e "GET /\r\nHost:rencontres-selection.com\r\n\r\n" | nc 88.191.110.117 80
[no reply]

So the DNS points to a host which isn't replying, for us. Perhaps it is only replying for you because of a firewall?

share|improve this answer
    
for ping and web browser is not replying. only for dig just like you did. –  Dan Bizdadea Oct 4 '11 at 9:49

Concerning the interfaces that are down after restarting the network:

Dedibox.fr offers KVM over IP. Just give them a call or email them to set it up for you. Then you will be able to take control over the server once again.

share|improve this answer
    
10x. i'll try that –  Dan Bizdadea Oct 4 '11 at 11:35
    
i did some time ago a configuration in /etc/netword/interfaces to set them static, because in case of a restart i had to manualy configure them every time. Is possible that i could have an error there? –  Dan Bizdadea Oct 4 '11 at 11:36
    
Probably. Post the contents of the file when you can get to it. –  Bart De Vos Oct 4 '11 at 11:43
    
I'm back. Seems the dedibox had an online interface that allowed us to reboot. After reboot it started with networking. The config file was fine. Everything is fine now. rencontres-selection.com works. I am still in the WTF mood. But it's clear it was something related to routing or whatever... i just don't know what. Do you have any ideea of some logs that i could check to make an ideea of what was happening ? –  Dan Bizdadea Oct 4 '11 at 12:50
1  
oki, thanks for your time. it really helped a lot :) –  Dan Bizdadea Oct 4 '11 at 14:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.