Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've found this error in my logs:

relocation error: /usr/lib64/libmyodbc5.so: symbol strmov, version libmysqlclient_16 not defined in file libmysqlclient_r.so.16 with link time reference


yum install mysqlclient16
184 packages excluded due to repository priority protections
Setting up Install Process
Package mysqlclient16 is obsoleted by mysql-libs, trying to install mysql-libs-5.1.59-1.el6.art.x86_64 instead
Package matching mysql-libs-5.1.59-1.el6.art.x86_64 already installed. 
Checking for update.
Nothing to do

i've used the atomicrepo using the latest mysql-version (mysql-5.1.59-1.el6.art.x86_64) on a server driven by CentOS6.


Plesk: This also appears in Plesk 10.3 > Application Vault as "Error 500"


edit: i've posted my solution as a response, maybe somebody will need it

share|improve this question
Which MySQL version are you running? –  quanta Oct 4 '11 at 9:15
And how did you install it? –  ℝaphink Oct 4 '11 at 9:26
i've updated the question, see above –  cept0 Oct 4 '11 at 9:30

2 Answers 2

I had the same error which I had fixed by installing mysql-libs.

yum install mysql-libs
share|improve this answer
up vote 1 down vote accepted

your mysql-packages seems to be destroyed or wrong configured (i aspect this happens only on centos6)

  1. For now I may advise you to dump all databases like:

    # mysqldump -uadmin -p`cat /etc/psa/.psa.shadow` --all-databases > /root/mysql.full.dump
  2. Then uninstall all MySQL related packages:

    # rpm -qa | grep mysql
    # rpm -e --nodeps `rpm -qa | grep mysql`
  3. Disable the atomic-repo in /etc/yum.repos.d

    enabled = 0
  4. Clean up yum:

    # yum clean all
  5. Then use autoinstaller and install them:

    # /usr/local/psa/admin/bin/autoinstaller
    Next > Next > Next:
    11 [x] MySQL server support
  6. Start MySQL-Daemon again

    # service mysqld start
  7. After that you may restore your databases:

    # mysql -uadmin -p`cat /etc/psa/.psa.shadow` < /root/mysql.full.dump

don't forget to re-enable the atomic-yum repository - Enjoy!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.