Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having a little difficulty understanding how I add a route in Windows Server 2008 (Web Edition).

I've been allocated a /64 (IPv6) subnet.

I added my IPv6 Address, Subnet Prefix and Default Gateway to the TCP/IPv6 Properties but I'm not sure how to add a "route."

My web hosts documentation says:

Since the gateway is in a different subnet, a route is necessary:

ip route add 2a01:4f8:61:20e0::1/59 dev eth0

ip route add default via 2a01:4f8:61:20e0::1

However, I don't know how to translate this and do it on a Windows server.

Is anyone able to give me any pointers?

Thanks,

share|improve this question
1  
That looks like a weird configuration. A /59 is not a normal subnet mask for IPv6, and having a default gateway that is in a different subnet than the subnet you are on is also weird. I have seen such configurations, but usually they indicate a very sub-optimal network design with a huge layer-2 domain... Do you have a link to your web hoster's documentation? –  Sander Steffann Oct 4 '11 at 17:38
    
Hi, Thanks for replying. Their documentation is at: wiki.hetzner.de/index.php/Zusaetzliche_IP-Adressen/en it's not very comprehensive and when I asked them if they would update it to include some guidance for Windows 2008 users they said "we haven't a instruction for windows server because it's very easy to add there something. If you need help to add the IPv6 address then please use google". Obviously Google was my first port of call... Thanks –  Andrew Duncan Oct 4 '11 at 20:52

2 Answers 2

Well to put it simply, the documentation is wrong. You cannot have a gateway that is not in "your" subnet. Since I think I understand what they meant, I'll try to correct it:

Dear Customer,

  • you have been placed in a subnet 2a01:4f8:61:20e0::1/59.
  • Please use a gateway 2a01:4f8:61:20e0::1, that is properly within your subnet.
  • But please do not use IP addresses out of the range 2a01:4f8:61:20e1::1/64. These addresses are not for you.
share|improve this answer
    
I tried 'netsh interface ipv6 add route 2a01:4f8:130:2260::1/59 "Local Area Connection"' but it's still not working. The IP's I have been assigned are: IPs: 2a01:4f8:130:2263:: /64 Gateway: 2a01:4f8:130:2260::1 /59 Useable IP addresses: 2a01:4f8:130:2263::2 to 2a01:4f8:130:2263:ffff:ffff:ffff:ffff –  Andrew Duncan Oct 5 '11 at 13:03

I would be fairly surprised if the gateway weren't 2a01:4f8:130:2263::1, especially seeing as though they say your first usable IP is 2a01:4f8:130:2263::2.

As stated above, the gateway needs to be within the interface's subnet -- which technically includes the link-local default gateway scenario.

share|improve this answer
    
How did you arrive at those addresses? –  Martijn Heemels Oct 10 '11 at 22:12
    
From Andrew's comment below, dated October 5th. For what it's worth, I'm now doubting my previous theory (since the logical router address is unresponsive); it genuinely seems like they have that bizarre of a network design. The best workaround I can think of is to use (/)59 for your subnet prefix length, and make certain you only use addresses from within your /64. That should allow connectivity with the router without any further tweaks. (Be sure you only use static IPv6 addresses -- you wouldn't want to even think about trying SLAAC with a configuration like that.) –  Jima Oct 11 '11 at 15:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.