Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The official repository of ubuntu 10.04 has an outdated memcached and i would like to have a newer version running on it.

What are your opinions ? Should i use couchbase membase server or I should I install the memcached from the repository and compile the source and just switch the binary file?

thanks for your help/opinions

update: i got a -1 point for the question , I really dont know why, Yes there are similar Q but they dont answer my question.

Installing memcached in Ubuntu server 9.04 http://serverfault.com/questions/214569/setting-up-memcached-memcache-with-php-on-ubuntu-10-10

share|improve this question
1  
What do you mean by outdated? Can't the old version store key-value pairs anymore? –  mailq Oct 4 '11 at 19:53
1  
You might consider enabling the backports repository. –  ceejayoz Oct 4 '11 at 19:54
    
Yes it does, you have a point, but even the developer of memcached is recommending to use 1.4.7 and ubuntu 10.04 has 1.4.2 . –  Elgreco08 Oct 4 '11 at 19:57
    
Some people on here are not at all forgiving (I was going to say less forgiving than others, but that's wrong). If you want to latest version of a binary, my suggestion is to download and build it from source (check that dependencies are all at acceptable version levels). You can then replace the file that is the binary as you wish. Some linux releases have package managers with assigned package repos that might not have the latest releases of some packages. CentOS is usually far behind as well, purposefully. –  mbrownnyc Oct 4 '11 at 20:08
    
You should probably have provided more information in your question. Do you already use a package management system like puppet or chef? Will you benefit from having the new memcached be integrated with the system? Does your application that uses memcached built in-house? Would it possibly be better to incorporate mecached into it so you know which version its using and the system won't be changing it without developers knowing? –  polynomial Oct 5 '11 at 1:49
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.