Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using Duply on top of Duplicity but apparently it fails (after 10 min on 100% cpu) on gnupg

--- Start running command BKP 21:10:58.679 ---
NcFTP version is 3.2.2
Reading globbing filelist /root/.duply/offsite/exclude
Local and Remote metadata are synchronized, no sync needed.
Last full backup date: Wed May 11 09:26:47 2011
GPGError: GPG Failed, see log below:
===== Begin GnuPG log =====
gpg: can't open `/root/.gnupg/random_seed': Too many open files
gpg: fatal: can't open /dev/urandom: Too many open files
secmem usage: 3712/3712 bytes in 8/9 blocks of pool 4096/32768
===== End GnuPG log =====

I have no clue on what to do?

share|improve this question

1 Answer 1

You need to figure out if you are running into a bug or generally need that many open files. One thing you can do is grab the output from lsof a few minutes into the run hopefully right before it fails. Look at the lsof output to see which files it has open. If you are using stock settings it is probably likely you just need to increase it:

http://www.cyberciti.biz/faq/linux-increase-the-maximum-number-of-open-files/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.