Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My boss just made several Windows updates to our server computer last night and in doing so we can no longer access the server from within the application.

I went on the server to try and see what the problem was and I get this message.

http://i.stack.imgur.com/MKDf7.png

Now I've been searching the internet all morning for solutions to a problem like this and I haven't found anything that has helped at all yet.

I tried making a new certificate on the localhost machine (server) hoping that the updated just messed up the certificate, which is why it doesn't approve of my authentication, however that didn't work.

The localhost machine is running IIS 5.1 on Windows XP Professional SP3.

Before the updates we had the .Net Framework 2.0 and after the updates we now have the .NET Framework 4.0 Client Profile with several security updates for both the .Net Framework 4.0 and Windows XP itself. There was an update for the Root Certificates and Visual Studio 2005 has been updated to Service Pack 1.

My questions are:

  • Has anyone every encountered this problem beforehand? If so, what was you solution?
  • It seems that the updates are the only reason why we can connect anymore, any ideas on which update broke everything and how to fix it?

Thank you for any help that you may provide.

share|improve this question

migrated from stackoverflow.com Oct 5 '11 at 3:55

This question came from our site for professional and enthusiast programmers.

1  
Have you checked if the account password hasn't expired..? Passwords needs to be changed if you do not set the password to never expire –  Oskar Kjellin Oct 4 '11 at 17:07
    
I agree with Oskar. The error message is telling you exactly what the problem is: that password has expired. Change it or mark the password as "never expires" while reenabling the account. I'm not sure why you would go down the path of creating a new certificate because it doesn't list any certicate errors. –  Chris Lively Oct 4 '11 at 17:34
    
Thanks for the suggestion guys, it's definitely working now! –  MPaul Oct 5 '11 at 14:06

1 Answer 1

up vote 3 down vote accepted

check in the IIS under which user the application is running and check for this user in the user management the checkbox "password never expires"

share|improve this answer
1  
+1 for the obvious... ;) –  Chris Lively Oct 4 '11 at 17:43
    
@ChrisLively +1 for copying my comment :D –  Oskar Kjellin Oct 4 '11 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.