Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to use an EC2 'micro' AMI (their recommended micro 32-bit AMI, ami-7f418316, which has kernel 2.6.35.14-95.38.amzn1.i686) to run a grails app (grails 2.0.0 BUILD-SNAPSHOT from github grails-core, so this is post-M2). It sometimes works, then sometimes when grails is starting up (before I do run-app) it will go into a 100% java or java + rsyslogd lockup, dumping a bunch of /var/log/message that look like there's something going on with memory mapping:

[180297.535565] ------------[ cut here ]------------
[180297.535572] WARNING: at arch/x86/xen/multicalls.c:182 xen_mc_flush+0x224/0x250()
[180297.535580] Modules linked in: ipv6 binfmt_misc dm_mirror dm_region_hash dm_log
dm_mod rtc_core rtc_lib ext4 mbcache jbd2 crc16 uhci_hcd ohci_hcd ssb ehci_hcd usbcore
nls_base [last unloaded: scsi_wait_scan]
[180297.535638] Pid: 24986, comm: java Tainted: G      D W   2.6.35.11-83.9.amzn1.i686 #1
[180297.535646] Call Trace:
[180297.535653]  [<c104282d>] warn_slowpath_common+0x6d/0xa0
[180297.535661]  [<c1004a44>] ? xen_mc_flush+0x224/0x250
[180297.535669]  [<c1004a44>] ? xen_mc_flush+0x224/0x250
[180297.535678]  [<c104287d>] warn_slowpath_null+0x1d/0x20
[180297.535686]  [<c1004a44>] xen_mc_flush+0x224/0x250
[180297.535694]  [<c10063ae>] ? xen_extend_mmu_update+0xce/0x190
[180297.535703]  [<c100650d>] xen_set_pud_hyper+0x9d/0xc0
[180297.535711]  [<c10065a4>] xen_set_pud+0x74/0xc0
[180297.535719]  [<c102cf90>] pud_populate+0x40/0x80
[180297.535726]  [<c10b1b73>] __pmd_alloc+0x73/0x80
[180297.535735]  [<c12aefd0>] ? do_page_fault+0x0/0x400
[180297.535743]  [<c10b63e2>] handle_mm_fault+0xd22/0xdc0
[180297.535751]  [<c1004922>] ? xen_mc_flush+0x102/0x250
[180297.535759]  [<c1005b06>] ? arbitrary_virt_to_machine+0x86/0xc0
[180297.535768]  [<c12aefd0>] ? do_page_fault+0x0/0x400
[180297.535776]  [<c12af0fc>] do_page_fault+0x12c/0x400
[180297.535784]  [<c1036df1>] ? finish_task_switch+0x41/0x90
[180297.535793]  [<c1048015>] ? irq_exit+0x35/0x70
[180297.535801]  [<c12aefd0>] ? do_page_fault+0x0/0x400
[180297.535809]  [<c12ac637>] error_code+0x73/0x78
[180297.535817]  [<c12a0000>] ? quirk_usb_early_handoff+0xd6/0x579
[180297.535824] ---[ end trace a7919e7f17c0c5a0 ]---

I've tried with both the openjdk and the sun jdk, same (intermittent) symptom. Any idea whether this is a clue that grails 2 is just not going to work on Amazon EC2, or is likely to be worth trying on a bigger instance? Or should I just shift over to cloudfoundry for grails apps these days?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I tried 32 and 64 bit micro versions of the Amazon Linux AMI: same (flaky) result. The 64-bit got killed faster (I think that's because there's no swap device on that AMI). So then I switched from the micro to a small 32-bit version and it's running fine. I didn't try any non-default memory tuning of grails, this will do for now.

share|improve this answer
    
Please mark this as your accepted answer :) –  pauska Oct 7 '11 at 12:34
    
OK (I wasn't sure about the ethos there). –  Wayne Oct 7 '11 at 21:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.