Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a few Windows 2008 servers that I'm trying to setup SNMP monitoring.

I have installed and configured the SNMP service. I have also turned on the exceptions from SNMP and SNMP Traps in the Windows Firewall exception list. However, SNMP traffic is still being blocked.

If I turn off the Windows firewall completely then the SNMP requests work fine.

Is there a known problem with the SNMP and SNMP Trap exception check boxes in the Windows Firewall settings? Is there another place that I need to configure to allow this traffic?

I know that the SNMP community strings are configured correctly (I have doubled checked, and everything works when the firewall is turned off).

Any ideas?

Thanks!

share|improve this question
up vote 6 down vote accepted

Some quick Googling seems to reveal that this is a bit of a known issue. I haven't found a workaround yet.

http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/c04736cd-9f62-499a-99b1-8b64f79afc66

EDIT: I am assuming you've added an exception for UDP/161, just like the guy in that forum post.

share|improve this answer
    
Testing adding the UDP/161 exception now. Will post the results. – Richard West Jun 25 '09 at 21:19
1  
Manually adding the UDP/161 exception worked. Makes me wonder what the predefined SNMP exception is allowing! – Richard West Jun 25 '09 at 21:25
    
TCP, possibly. You can do SNMP over TCP but it's not recommended, especially if the network is having trouble. – Boden Jun 25 '09 at 22:58

SNMP is a service that uses UDP as its transport protocol also and is connectionless. Verify your settings are allowing UDP traffic for the SNMP port 161 as defined in RFC 768.

share|improve this answer

Are you trying to query SNMP from a different subnet? The default SNMP Firewall rule is set to Remote Address: Local subnet if you are not in a domain!

share|improve this answer

I had the same problem and same workaround as mentioned by KPWINC and just learned from someone else here that the problem can be fixed by going to advanced firewall and change scope. Also make sure the rule is valid under the network scope the server is currently in (See the Advanced tab.).

share|improve this answer

I know this is an old post, but I'm leaving a message here for the future.

I've found two situations that happened not to be firewall related even though that was the first place I looked. After reviewing the firewall logs I found that the inbound UDP 161 requests were being accepted.

  1. In Services, check the Security tab on the SNMP service and ensure that you are allowing connections from the proper IP addresses and have the proper community string set up.

  2. I've found in rare cases some applications will take over port 161. In this case, go to C:\Windows\System32\Drivers\etc\ and edit "services" (you'll probably need to run notepad.exe as administrator) to give SNMP a different port - 1616 perhaps. Apply appropriate firewall rules and restart the SNMP service.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.