Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a few Windows 2008 servers that I'm trying to setup SNMP monitoring.

I have installed and configured the SNMP service. I have also turned on the exceptions from SNMP and SNMP Traps in the Windows Firewall exception list. However, SNMP traffic is still being blocked.

If I turn off the Windows firewall completely then the SNMP requests work fine.

Is there a known problem with the SNMP and SNMP Trap exception check boxes in the Windows Firewall settings? Is there another place that I need to configure to allow this traffic?

I know that the SNMP community strings are configured correctly (I have doubled checked, and everything works when the firewall is turned off).

Any ideas?

Thanks!

share|improve this question

4 Answers 4

up vote 3 down vote accepted

Some quick Googling seems to reveal that this is a bit of a known issue. I haven't found a workaround yet.

http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/c04736cd-9f62-499a-99b1-8b64f79afc66

EDIT: I am assuming you've added an exception for UDP/161, just like the guy in that forum post.

share|improve this answer
    
Testing adding the UDP/161 exception now. Will post the results. –  Richard West Jun 25 '09 at 21:19
    
Manually adding the UDP/161 exception worked. Makes me wonder what the predefined SNMP exception is allowing! –  Richard West Jun 25 '09 at 21:25
    
TCP, possibly. You can do SNMP over TCP but it's not recommended, especially if the network is having trouble. –  Boden Jun 25 '09 at 22:58

SNMP is a service that uses UDP as its transport protocol also and is connectionless. Verify your settings are allowing UDP traffic for the SNMP port 161 as defined in RFC 768.

share|improve this answer

Are you trying to query SNMP from a different subnet? The default SNMP Firewall rule is set to Remote Address: Local subnet if you are not in a domain!

share|improve this answer

I had the same problem and same workaround as mentioned by KPWINC and just learned from someone else here that the problem can be fixed by going to advanced firewall and change scope. Also make sure the rule is valid under the network scope the server is currently in (See the Advanced tab.).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.