Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Short question is. I have a domain name mydomain.com, we have a company website hosted on an IIS server 2003 configuration. Going to the address bar and typing www.mydomain.com will show my website properly. Typing mydomain.com into the same address bar will return an under construction website that seems to be hosted on my webserver.

My domain name is hosted by Network Solutions, and I think I have it configured correctly using their advanced DNS services. In their settings I have www.mydomain.com, * and @ also pointed to the ip address of my webserver.

On my webserver itself using the IIS manager, under the Web Site, and Web Site Identification. I have configured both www.mydomain.com and mydomain.com configured to work on the IP address on the webserver.

I am hosting 4 different websites on my IIS server, all the other sites use prefixes other than www, an example is mail.mydomain.com and a couple of others. None of them show an under construction page as their default homepage. I am really at a loss as to why it would show an under construction page, especially since it seems to be pointing to the correct server.

The reason this is such a big deal is because when you search for my company on google, the link there is for mydomain.com and by clicking on the link it shows under construction which is really quite embarrassing.

Thanks in advance for any help and if there are further questions let me know.

share|improve this question
    
I edited the name out just because I would prefer it to be anonymous. –  user10711 Jun 25 '09 at 21:05
    
Internally we do have a different dns server, which I am not too concerned about. But it seems that from some locations it does not resolve correctly. For example my phone which would use a public DNS server it returns the under construction page. Maybe their DNS server is just not updated yet? –  user10711 Jun 25 '09 at 21:07
    
Like Whipartist said, if you recently updated the DNS record then the DNS server that your phone is using could have the cached DNS record. It will expire after the TTL settings. On your local system, is running Windows, you can issue the following command to flush your DNS cache: IPCONFIG /FLUSHDNS –  Richard West Jun 25 '09 at 21:33

5 Answers 5

up vote 2 down vote accepted

How recently did you set up the DNS? If it was very recently, you may be getting cached zone files. Do you know what the TTL is for them? Are you sure you updated the serial number?

share|improve this answer
    
I think part of my problem was some of the DNS servers had not been fully updated. Cached. Problem should solve itself shortly. –  user10711 Jun 25 '09 at 21:42
    
By the way, you can test the webserver configuration by telnetting to port 80 and making a manual HTTP request. telnet IP_ADDR 80 GET / HTTP/1.1 Host: www.mydomain.com (followed by two carriage returns) Then do the same thing with Host: mydomain.com. If you get the same results for both, then your webserver is OK. –  user10501 Jun 26 '09 at 1:26

I think your DNS settings are fine.

Both www.altusenergy.com and altusenergy.com resolve to the website for me.

This is more than likely a problem with your internal DNS server, that is serving the IP address to your local systems.

To the outside world you are good.

share|improve this answer
    
can you search it on google and try from there? Thats where I was having the issue. –  user10711 Jun 25 '09 at 21:05
    
Both www.altusenergy.com and altusenergy.com work for me as well. I'm using OpenDNS.org as for my DNS servers. –  KPWINC Jun 25 '09 at 21:08
    
I searched Google for altusenergy, the first record returned is your website at altusenergy.com. Clicking on it worked OK for me. FYI - you can also click on the cached version that Google returns. This will show you what the Googlebot downloaded from your site on it's most recent visit. –  Richard West Jun 25 '09 at 21:30

If "altusenergy.com" is indeed "mydomain.com" then it resolves to a web site fine for me. Perhaps you have a different mapping inside your domain, which is common if you're also using domain.com as your AD DNS suffix?

share|improve this answer

When web browsers pull requests they normally perform a 'GET /index.html'. Each site should have its own index.html or index.htm. I would check to make sure that your settings are correct for these. You can specify defaults in your IIS snap-in.

share|improve this answer

That's what network solutions does to everything you haven't registered with them. Check out -> http://dude.chartright.us/ for instance...

share|improve this answer
1  
Forwarding * to the correct ip with their ADNS service will get rid of those problems, and @ is supposed to forward no prefix. –  user10711 Jun 25 '09 at 22:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.