Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have this question. There's a lot of information out there but none of the things I tried helped and I am still unable to identify if it can be helped at all.

I have a site originally with a provider. Later I transferred the DNS to another web hosting site but the DNS settings are still visible on the original domain registrar.

So what happens is the site will display at www.domain.com but not when I put domain.com

I've checked the CNAME settings on both the original provider and the new one and appear to be correct. I've also tried to enable forwarding using an .htaccess file and that failed too (although some other redirects seem to work well).

I can't identify where else to look in order to finally get domain.com working! Could it be some sort of limitation on the new web host that forbids that sort of thing? (even though there is a CNAME setting present) Any help will be greatly appreciated. This has been troubling me for over a month!

Thank you


UPDATE 10/10/11

I am trying to make sense of all this. The domain is fineenergy.co.uk (or www.fineenergy.co.uk is the one that actually works)

By doing a NSLookUp I get much more results than www.fineenergy.co.uk

I think, as you said, either the A record or the CNAME records is missing but after checking the DNS settings I find that both records are there. In detail: A Record Host fineenergy.co.uk Points to 66.96.147.104 CNAME Record Host fineenergy.co.uk Points to www.fineenergy.co.uk

Not sure what else I could add to that. The only other thing I can think of is that these settings are ignored in favour of the original host's settings.

Any other suggestion would be very welcome. Thank you guys for the help!

share|improve this question
    
What displays instead without www? –  Alex Oct 4 '11 at 14:18
    
When I ping it says "Could not find host" and same for the browser. It says "page not found" depending on the browser –  Nick Oct 10 '11 at 10:17
    
Well changing this worked but the email stopped working :-( I am not trying a combination of getting the name server to point to 66.96.147.104 and then leaving the MX record for the email to go through the original server... LEt's hope this works??? There's no option to choose the new provider's name servers without automatically messing up the MX records. Could transferring the domain be the only way? –  Nick Oct 12 '11 at 13:51
add comment

migrated from stackoverflow.com Oct 5 '11 at 13:26

This question came from our site for professional and enthusiast programmers.

3 Answers

up vote 1 down vote accepted

Without seeing the actual records, you will want to do a DIG (or NSLOOKUP) on the domain and look for what gets returned with and without the www.

This is how stackoverflow.com is set up. If you are missing either a CNAME or an A record for both the www and without, that is your issue.

stackoverflow.com.  1200    IN  A   64.34.119.12
www.stackoverflow.com.  1200    IN  CNAME   stackoverflow.com.

If you post the domain, we can better help. Also, this question should be on serverfault.com , I have requested it be moved there as it is not programming related.

EDIT: 10/10

Since you are seeing the A record, but the internet is not, it is possibly due to the domain pointing to the wrong name servers.

Name servers:
        dns1.fluent.ltd.uk        195.78.94.253
        dns2.fluent.ltd.uk        195.78.94.254

You mentioned switching web hosts, if that is not your current web host then you need to contact 1 & 1 AG and have them change the name servers over to your current web host so the internet sees the correct DNS records.

share|improve this answer
    
I've added the details under my question –  Nick Oct 10 '11 at 10:17
    
Ah!! Not sure if I did the right thing, but I changed the name servers of the original provider to those of the new provider. I'll check if that works and if it does, I'll mark your answer as the solution. Many thanks! –  Nick Oct 12 '11 at 9:56
    
Looks to be working to me. fineenergy.co.uk redirects to www.fineenergy.co.uk with no errors :) –  Drazisil Oct 13 '11 at 6:11
    
Yeah it's after I changed the name servers that this worked! Marking this as answered :-) –  Nick Oct 13 '11 at 12:57
add comment

Now you've posted the domain we can see that the root domain (without the www) hasn't been configured in the DNS

www.fineenergy.co.uk has an A record pointing to 66.96.147.104 but nothing is listed for fineenergy.co.uk

You need to add an A record for fineenergy.co.uk pointing to 66.96.147.104


EDIT: Okay having looked again it seems a bit more complicated...

Nominet says that your nameservers should be ns1.ipage.com and ns2.ipage.com but dig is saying that your NS records are set to be dns1.fluent.ltd.uk and dns2.fluent.ltd.uk in the zone

Looking up fineenergy.co.uk on dns1.fluent.ltd.uk or dns2.fluent.ltd.uk shows there is no record

Looking up www.fineenergy.co.uk on dns1.fluent.ltd.uk or dns2.fluent.ltd.uk shows an A record to 66.96.147.104

Looking up fineenergy.co.uk on ns1.ipage.com and ns2.ipage.com shows a CNAME record pointing to www.fineenergy.co.uk which is against DNS rules

Looking up www.fineenergy.co.uk on ns1.ipage.com and ns2.ipage.com shows an A record to 66.96.147.104

No nameserver records appear to be in the ns1.ipage.com and ns2.ipage.com zone.

share|improve this answer
    
On the control panel I see that there is an A record for fineenergy.co.uk pointing to 66.96.147.104, but there isn't one for www.fineenergy.co.uk. And yet it's only the latter that works. –  Nick Oct 12 '11 at 9:55
add comment

This may not be related to DNS. You web server also may need to be configured to handle domain.com in addition to www.domain.com. i.e., it needs to be told that it is serving content for domain.com, and where the content is located. If you were on apache, one way to do this is by configuring a ServerAlias setting under your original domain config.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.