Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My server is running Ubuntu 10.04 and is connected by ethernet to a router/modem device. The problem is that it's basically ignoring incoming connections. So I can't SSH into it or access the webserver. It wont even accept connections from other machines within the network.

However, it can make outbound connections fine. When it starts up it successfully sends me the startup email (connects to gmail SMTP servers etc). It can also perform DNS requests and get the response fine, after trying "dig". ethtool and ifconfig confirm that the server is connected and has the usual internal IP address.

The strange thing is that on the routers control panel, there are no signs of the server being connected at all. The server does not connect using DHCP, but manually defined settings. I've double checked the config and everything is fine (as it should be - I haven't changed anything).

This is a pain to troubleshoot, so could anyone give me any pointers on what the problem may be? I'm having to read commands out over the phone because I can't just SSH in and play around.

share|improve this question
    
have you installed a firewall? messed around with ip tables? what router have you got? –  Aceth Oct 5 '11 at 14:56
    
I was just about to add that - no I don't have a firewall and haven't touched iptables. My router is a BT HomeHub 3! –  Matt Oct 5 '11 at 14:58
    
did this problem crop up after a server reboot? if so it very well could be an issue with the firewall if you stopped the service which was started upon the server rebooting. –  Dave Oct 5 '11 at 17:07

1 Answer 1

up vote 0 down vote accepted

First thing I would look at is the firewall configuration on the server itself, i.e. IPTABLES; it's quite usual for a freshly-deployed server to not allow any incoming connection.

The second thing would be the router's configuration. If that router is doing any kind of NAT and/or firewall, you will of course not be able to access your server from the outside.

share|improve this answer
    
It's been running fine for around 6 months, and the last time I even SSH'd into the server was about a week before it failed. Could iptables change without input from me? The problems seem to vary slightly too - I just managed to connect to the server from an internal machine after a series of resets. But still no presence on the router page, and not working again. Could it be a hardware issue? –  Matt Oct 5 '11 at 15:04
    
if that's the problem, iptables -F should clear most of the cruft and let you connect. What's iptables -L saying? –  Alien Life Form Oct 5 '11 at 15:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.