Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Munin working just fine, but any time I try to do cgi graphing - it just stops graphing... no errors in the log, nothing. I've followed the instructions here: http://munin-monitoring.org/wiki/CgiHowto - and it should be working - here's my munin.conf setup, at least the parts that matter:

dbdir   /var/lib/munin
htmldir /var/www/munin
logdir  /var/log/munin
rundir  /var/run/munin

tmpldir /etc/munin/templates

graph_strategy cgi
cgiurl /usr/lib/cgi-bin
cgiurl_graph /cgi-bin/munin-cgi-graph

And then the host info yada yada - graph_strategy cgi and cgrurl are commented out in munin.conf - that's because if I uncomment them, graphing stops working. Again, I get no errors in logs, just blank images where the graphs used to be. Comment out cgi? As soon as munin html runs again, everything is back to normal.

I'm running the latest version of munin and munin-node - I've tried fastcgi and regular cgi - permissions for all of the directories involved are munin:www-data - and my httpd.conf file looks like this:

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
 <Directory /usr/lib/cgi-bin/>
 AllowOverride None
 SetHandler fastcgi-script
 Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
 Order allow,deny
 Allow from all
 </Directory>
 <Location /cgi-bin/munin-cgi-graph>
 SetHandler  fastcgi-script
 </Location>      

Does anyone have any ideas? Without this working, at least from what I understand, Munin just graphs stuff, even if no one is looking at them - you add 100 servers to graph, and this starts to become a problem. Hope someone has ran into this and can help me out.

Thanks!

share|improve this question

2 Answers 2

With CGI Graphing the graphs are obviously generated when requested.

A starting place to look for the problem is the log files (usually /var/log/munin/munin-cgi-graph.log). You should find some stuff there to at least help you further troubleshoot the problem.

I've fought over and over with munin CGI Graph and it's ALWAYS a permissions issue. I would definitely look into that. It's important to note that the CGI graphing tool for some reason still wants access to your htdocs directory, atleast in my experience. It seems to be tied to munin-html.

Bottom line is to check the logs, check the permissions. You'll likely find something in munin-cgi-graph.log which is useful.

share|improve this answer
    
Reenable cgi graphing, just for kicks, and I AM getting an error - but I don't know what to do with it: Warning: Unknown option "graph_printf" I can find one bug thread regarding this, and graph_printf is supposedly supported any version after 1.3.3 The entire error message is the following: Oct 05 15:35:19 - Warning: Unknown option "graph_printf" in "<groupname>;<servername>:users.graph_printf". –  Vaughn Hawk Oct 5 '11 at 22:47
    
Nevermind... it IS a version issue. I'm running 1.2.6, which as far as I can tell is the latest version available for debian via apt-get - and it looks like the upgrade path is purely from source... which sucks, because I have quite a few servers to upgrade, and the upgrade path could potential cause some issues with plugins (easily fixable, but I don't want to fix something 100 times...) - anyway gotta be a way to get it to work, at least I know my permissions are good. –  Vaughn Hawk Oct 5 '11 at 23:28
    
The "graph_printf" is a option that is passed to rrd tool. If you grep /usr/share/munin/plugins/ for any file containing "graph_printf" you can try a few things. You can remove that line and see if the graphs are still readable (likely it just adds a line of text somewhere on the graph), or you can disable that plugin (if it's not necessary). –  Caesar Kabalan Oct 5 '11 at 23:51

This may not help the original poster but I couldn't get my graphs to generate using "graph_strategy cgi", graphs were simply empty images.

To get around this I simply commented out "graph_strategy cgi" from my /etc/munin/munin.conf file and graphs show fine.

I think "graph_strategy cgi" is commented out by default but a tutorial I read asked me to uncomment that...it may help others wondering why graphs/images aren't showing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.