Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Server runs just fine, but I'm receiving messages like:

httpd failed @ Wed Oct  5 17:49:03 2011. A restart was attempted automagically.
Service Check Method:  [tcp connect] 
Failure Reason: Service check failed to completehttpd: [ != HTTP/1..]
Number of Restart Attempts: 4215

Here's the result of this: grep -i maxclient /usr/local/apache/logs/error_log

(just blank row)

Here is the result of this: service httpd status

    Apache Server Status for localhost

   Server Version: Apache/2.2.14 (Unix) mod_ssl/2.2.14
          OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1

mod_bwlimited/1.4 FrontPage/5.0.2.2635

   Server Built: Feb 22 2010 13:38:49

   Current Time: Wednesday, 14-Sep-2011 21:16:56 BST
   Restart Time: Wednesday, 14-Sep-2011 21:12:44 BST
   Parent Server Generation: 0
   Server uptime: 4 minutes 11 seconds
   Total accesses: 192 - Total Traffic: 2.6 MB
   CPU Usage: u.11 s.07 cu31.76 cs0 - 12.7% CPU load
   .765 requests/sec - 10.5 kB/second - 13.7 kB/request
   1 requests currently being processed, 9 idle workers

_.._W_______....................................................
................................................................
................................................................
................................................................

   Scoreboard Key:
   "_" Waiting for Connection, "S" Starting up, "R" Reading

Request, "W" Sending Reply, "K" Keepalive (read), "D" DNS Lookup, "C" Closing connection, "L" Logging, "G" Gracefully finishing, "I" Idle cleanup of worker, "." Open slot with no current process 

Well, I tried to see what's in the /usr/local/apache/logs/error_log

[Wed Oct 05 17:46:34 2011] [error] [client (IP address)] File does not exist: (path to one of the site folders), referer: (one of site pages)
[Wed Oct 05 17:46:44 2011] [error] [client (IP address)] File does not exist: (path to one of the site folders), referer: (one of site pages)

(somewhere here server failed)

[Wed Oct 05 17:49:05 2011] [notice] caught SIGTERM, shutting down
[Wed Oct 05 17:49:05 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
dotDefender License OK Free version
[Wed Oct 05 17:49:05 2011] [notice] Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 configured -- resuming normal operations

It corresponds the last time I've received the message:

httpd failed @ Wed Oct  5 17:49:03 2011....

2 seconds later Apache reports it's up again. But there's nothing in logs before the startup (well, error 404 because of abscent file couldn't kill the server, I believe). What can cause it? The server is hosted at VPS.net, if it's important.

share|improve this question

1 Answer 1

You are correct, the 404 errors are not the cause of this. You say this is on a VPS, what kind of memory do you have available? If you are running out of memory due to a lot of requests (think Google spidering the page), the kernel may kill Apache to free up some memory. Check syslog (less /var/log/messages) and see if you see any lines about OOM.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.