Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We moved a few websites to an Apache2 setup and have since not been able to connect to the server with SFTP. I get a password / username error. There is no load on the server. SSH is configured. Permissions are correct. I can access it via WinSCP, Dreamweaver and Putty, but not Contribute. Anyone have any clues here?

Here is some more server info:

Apache2
SUSE Linux Enterprise Server 10 (i586)
VERSION = 10
PATCHLEVEL = 3
/etc/SuSE-release

apache2ctl -V

Server version: Apache/2.2.3
Server built:   Apr 14 2010 11:41:47
Server's Module Magic Number: 20051115:3
Server loaded:  APR 1.2.2, APR-Util 1.2.2
Compiled using: APR 1.2.2, APR-Util 1.2.2
Architecture:   32-bit
Server MPM:     Prefork
  threaded:     no
    forked:     yes (variable process count)
Server compiled with....

 - -D APACHE_MPM_DIR="server/mpm/prefork"  -D APR_HAS_SENDFILE  -D
   APR_HAS_MMAP  -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)  -D
   APR_USE_SYSVSEM_SERIALIZE  -D APR_USE_PTHREAD_SERIALIZE  -D
   SINGLE_LISTEN_UNSERIALIZED_ACCEPT  -D APR_HAS_OTHER_CHILD  -D
   AP_HAVE_RELIABLE_PIPED_LOGS  -D DYNAMIC_MODULE_LIMIT=128  -D
   HTTPD_ROOT="/srv/www"  -D SUEXEC_BIN="/usr/sbin/suexec2"  -D
   DEFAULT_PIDLOG="/var/run/httpd2.pid"  -D
   DEFAULT_SCOREBOARD="logs/apache_runtime_status"  -D
   DEFAULT_LOCKFILE="/var/run/accept.lock"  -D
   DEFAULT_ERRORLOG="/var/log/apache2/error_log"  -D
   AP_TYPES_CONFIG_FILE="/etc/apache2/mime.types"  -D
   SERVER_CONFIG_FILE="/etc/apache2/httpd.conf"
share|improve this question
    
thanks SvenW :) –  jasonflaherty Oct 5 '11 at 22:58

1 Answer 1

Does contribute cache "known hosts" values? Perhaps it's failing expecting a different ssh key for the site.

share|improve this answer
    
I don't think so. I've deleted all the server files associated with Contribute and still get the issue.... –  jasonflaherty Nov 9 '11 at 23:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.