Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a VPS running Ubuntu 10.04 that I want to simulate network latency on. It looks like tc is what I want to use, and I pulled this command from the examples from here:

# tc qdisc add dev eth0 root netem delay 100ms

If I run this command, I get this error message:

$ sudo tc qdisc add dev eth0 root netem delay 100ms
RTNETLINK answers: No such file or directory

I suspect that I might be missing whatever makes this command work. Searching lead me to believe that there might be kernel modules needed, but I couldn't be sure. I ran lsmod on the machine and it comes up empty.

So, I'm lost. How can I get my simulation working?

share|improve this question

It's quite normal for a VPS image to be missing things found in a "regular" install, such as the many commands that are normally not required in such an environment. If you want something that's not there go through the normal install process.

share|improve this answer
Sounds reasonable. What is missing that I need to install, or, how can I find out? The link I found seems to be the main resource for this component but I see what it depends on. – phasetwenty Oct 6 '11 at 17:39
@phasetwenty, as I don't use Ubuntu or tc I'll leave it to someone familiar with that distro to go over the install procedure. – John Gardeniers Oct 6 '11 at 20:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.