Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I do have a server 2008 64 running a SQL server 2005. I do have 8GB on the server and I want SQL to use most of the memory on that server. I have turned the page-locking on for the account and also turned AWE on. See the result below:

Configuration option 'min server memory (MB)' changed from 0 to 1024. Run the RECONFIGURE statement to install.

Configuration option 'max server memory (MB)' changed from 5113 to 6144. Run the RECONFIGURE statement to install.

However it does not seem that SQL server is loading the memory. Not sure what I am missing. I would appreciate if someone could lead me on the right direction.

share|improve this question

2 Answers 2

64-bit versions of Windows don't support AWE. "AWE is not required and cannot be configured on 64-bit operating systems."

share|improve this answer
    
Then how could I make my SQL server 2005 use more memory? –  Ridvan Oct 6 '11 at 14:08
    
Install the 64-bit version of SQL server 2005. –  David Schwartz Oct 6 '11 at 15:17
    
I agree with David. What edition SQL Server are you running? Can you post back the result of this query: SELECT SERVERPROPERTY('Edition') AS 'Edition' –  DaniSQL Oct 6 '11 at 15:39
    
Play_demo 204.992187 SmarterTrack 4.312500 EasyLoanChoice 2.109375 BugTracker2 0.671875 HotBargainHunter 0.500000 As you see not using almost any memory at all. I am using a 2005 Enterprise x86 version. I do have the same thing on another server running Windows 2003 but in there SQL server takes all the memory that is assigned. Not sure what else to do to SQL server 2005 x86 or to Windows 2008 x64. –  Ridvan Oct 6 '11 at 21:24
1  
As @DavidSchwartz said try upgrading to x64 of SQL Server. –  DaniSQL Oct 10 '11 at 19:54

Try running this below query (by Glen Berry); and see "how much memory (in the buffer pool) is being used by each database on the instance"

SELECT  DB_NAME(database_id) AS [Database Name] ,
        COUNT(*) * 8 / 1024.0 AS [Cached Size (MB)]
FROM    sys.dm_os_buffer_descriptors
WHERE   database_id > 4 -- system databases
        AND database_id <> 32767 -- ResourceDB
GROUP BY DB_NAME(database_id)
ORDER BY [Cached Size (MB)] DESC
OPTION  ( RECOMPILE ) ;

The min and max memory allocation depends on your workload; Read Effects of min and max server memory for more detail

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.