Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I already solved this problem, but I'm posting it here for future reference.

Scenario:

  • You have two (or more) VMware vCenter servers in linked mode.
  • You have the same permissions on all of them.
  • You are not a local Administrator on the server themselves.
  • You can successfully connect to each one of the vCenter servers using the vSphere Client.

Symptoms:

  • When you connect to a vCenter server, you get an error about an authentication failure connecting to the other linked one(s), and you can't access it/them in the client.
  • This happens when connecting to any one of the linked vCenter servers: you can only access the one you're connected to, not the other linked one(s).
share|improve this question

2 Answers 2

up vote 4 down vote accepted

Turned out that, in order to remotely access a linked vCenter server, you need the "log on as a batch job" Windows right on the server, which only local Administrators have by default.

If you grant your user account this right (directly or through a local or domain group) on all linked vCenter servers, you'll be able to successfully access all of them when connecting to one, which is the exact purpose of setting them up in linked mode in the first place; all VMware permissions continue to apply as usual, this additional right only enables you to connect to linked vCenter servers.

The right can be configured in the local security policy of the servers ("User rights assignment" section), or via AD Group Policies.

This is completely undocumented by VMware, BTW.


Update:

It finally got documented: http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&externalId=1025991.

share|improve this answer
    
That's very strange. Good find! –  Shane Madden Oct 6 '11 at 15:00

OK I had this issue and as I know you DO NOT require the Log on as a Batch job right I did some more digging.

Turns out I had some old idle sessions > 60 days, why I do not know.

I terminated these sessions on both hosts, disconnect and reconnect and viola!

all Good now.

share|improve this answer
2  
Seems that the VMWare KB article in the accepted answer disagrees with your assertion that it's not required. –  MDMarra Feb 23 '12 at 22:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.