Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an issue with CentOS route... maybe someone can help me to figure it out, how to simple configure route... I have an dedicated ip adress e.g. 13.97.82.85 my netmask is 255.255.255.192 and gw is 13.97.82.65 all I want to do to connect to the internet... Now I have route like this:

Destination             Gateway       Genmask          Flags   Metric   Ref    Use   Iface
13.97.82.64             *             255.255.255.192  U       0        0        0   seth0
default                 13.97.82.65   0.0.0.0          UG      0        0        0   seth0

I can't understand from where comes 13.97.82.64 IP adress? in network configuration files (ifcfg...) everything seems correct, also I set NOZEROCONF=yes.

With DNS everything seems correct, I can resolve address, but I can't ping...

Maybe, someone could help me?

share|improve this question
2  
13.97.82.64 is the start of your subnet that you reside in - in case, a /26 subnet. Can you at least ping the gateway? –  Rilindo Oct 6 '11 at 17:53
    
Thanks for answering me. I can't ping my default gateway. Maybe other suggestions? Thanks in advance. –  Brian Oct 6 '11 at 20:17
    
If you can`t ping the gateway it propably is no gateway. Where did you get the gateway-address from? –  Nils Oct 6 '11 at 20:49
    
from my data center, on other servers working without any issue... Thank You. –  Brian Oct 6 '11 at 20:54
    
ups... I forgot to swich off firewall, no it's ok. I can ping default gateway. Thanks! –  Brian Oct 6 '11 at 21:02

1 Answer 1

up vote 0 down vote accepted

According to your config

Network:   13.97.82.64/26
HostMin:   13.97.82.65
HostMax:   13.97.82.126
Broadcast: 13.97.82.127
Hosts/Net: 62

13.97.82.64 is network address for /26 net. Route table always contain route to base net

I can resolve address, but I can't ping...

If DNS-resolver placed inside your /26 net - your packets for resolving doesn't leave it. For ICMP-pings situation differ - pACKETS must go after default-gw. Possible troubles

  • icmp echo-reply disabled on gw (traceroute some-kbown-exrertal-ip for test)
  • IP-forward disabled on GW (traceroute again)
  • smth. more, have to think
share|improve this answer
    
Thank you for answering me. I will try to call to my data center, maybe they add some restrictions or smth to this server. Thank you! –  Brian Oct 6 '11 at 23:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.