Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed the Management Service role and the service will not start. Google is no help as this seems to be some really rare error. I am hoping someone can help though.

This is on IIS 7.5 on Windows Server 2008 R2. I think the problem may be because I have a wildcard certificate installed for *.foo.com because IIS can't even handle multiple SSL-enabled hostnames.

The service seems to have created its own private SSL certificate. Perhaps there's a way to specify through the commandline which cert the managed service should be using?

This is the error in Event Viewer :

The Web Management Service service terminated with service-specific error %%-2147483640.
share|improve this question

1 Answer 1

The problem seems to have been related to the already installed wildcard certificate. Here's what needs to be done.

First the DO NOT use the Web Platform installer, follow these Web Management Install directions.

At the end of that post the part about starting the wmsvc will still fail. Ignore that for now.

Once installed goto the Management Service Delegation and make sure Administrators are allowed to bypass Rules in the Feature Settings.

Then goto Management Service. It should no longer be greyed out. Select the self-signed SSL certificate from the drop-down. You should now be able to start the service.

This probably will come up on other installs if you already have a certificate installed. It seems Management Service cannot figure out what to do when there is more than one certificate. Probably expects to be enabled from the start before anything else is done.

share|improve this answer
    
This solved my problem, although in this case I had the error code 2147483656 (0x80000008). –  Neil Jun 18 '12 at 8:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.