Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently purchased a quite expensive Rootserver. The only way to connect to it is via SSH. That works perfectly fine and I'm happy with it. But sadly, my boss wants a GUI. SO my first thought was: VNC.

I literally tried everything. I did over 50 Serverresets and everytime I started from scratch.

Can someone give me instructions to get that running?

share|improve this question
What errors or issues were you seeing? Also - did you install a GUI of any kind for VNC to present? Ubuntu's server distribution doesn't come with one. You'd need to apt-get install ubuntu-desktop. Or, just tell your boss that the server doesn't have a GUI. – Shane Madden Oct 6 '11 at 21:17
A console is not a GUI. Sounds logic? Is logic. – mailq Oct 6 '11 at 21:30
Are you sure you don't want a web-based admin panel instead? See… – Zoredache Oct 6 '11 at 21:51
Also see X11 forwarding with putty,… – Zoredache Oct 6 '11 at 21:53
Of course i tried it with Gnome installed ;) No, I really need a VNc connection, just like RDP. I#ll have a look at X11. Thanks :) – buschtoens Oct 6 '11 at 22:06
up vote 2 down vote accepted

Firewall Settings

Have you checked the firewall settings? You need to set TCP port 5800/5801 open (depending on set up - you could use an ssh tunnel, but that is more complicated). Note that various root server providers have firewalls set up between you and the root server, so you may have to go into a web interface to open up the relevant port. For example with Amazon EC2 you would have to run ec2-authorize to let traffic through, as well as opening up the port on the server itself.

VNC server

You then need to start the VNC server, and only then can the client connect to the server. We use xtightvnc as it is meant to be good at compression. An initial step is to set up your VNC password - the password you will have to type into your VNC client to join the VNC session. To do this you use vncpasswd (man page) on the console on the server.

So to start the server on display 1 (so port 5801) you need to run something like this command on a console on the server, as the user you want to be:

tightvncserver -geometry 1024x768 -depth 15 :1

See the man page for more details on the various options. Then you can connect with your client, to port 5801.

Web options

As well as the desktop client, there are also a couple of options for running VNC in the browser. For older browsers there is a VNC client java applet that will run in the browser. For more modern browsers (with the HTML 5 Canvas element) you can run Guacamole - a java service that lets you have a VNC session run directly in your browser. (Strictly it is running its own special protocol, and the guacamole service running on your server translates that into VNC. So for guacamole to work you also need port 4822 to be open.)

Automating it all

I know by this point I'm getting away from directly answering the question a bit, but I did some fun stuff to automate setting up, joining and tearing down VNC sessions using fabric (a python deployment library) I'd like to share. Read the link to learn more.

share|improve this answer
Pssst, little hint: He has no XServer running. So VNC is useless in that scenario. – mailq Oct 6 '11 at 23:36
@mailq - he says he has Gnome installed, and on Ubuntu at least that starts on boot by default. (Not sure about Red Hat based distros though). But I agree the question leaves an awful lot of unknowns. Also I thought my answer would be useful for those who find this question from google, even if the original question writer has other issues. – Hamish Downer Oct 7 '11 at 13:23
Your answer is perfect!! But not for the question. His Gnome comment really looks ironic to me (based on the smiley and the following "no"). In the question he talks about Ubuntu minimal which definitively has no GUI (X11). – mailq Oct 7 '11 at 13:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.