Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm not able to set ACL on file/directories. Below is the data copied from my terminal.

-bash-4.1$ setfacl -m u:asagar:x TestACL
setfacl: TestACL: No space left on device

-bash-4.1$ df -ahi
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
/dev/mapper/vg_server01-lv_root
                    546K     46K    500K    9% /
proc                       0       0       0    -  /proc
sysfs                      0       0       0    -  /sys
devpts                     0       0       0    -  /dev/pts
tmpfs                    35K       1     35K    1% /dev/shm
/dev/sda1               126K      38    125K    1% /boot
none                       0       0       0    -  /proc/sys/fs/binfmt_misc
sunrpc                     0       0       0    -  /var/lib/nfs/rpc_pipefs


-bash-4.1$ uname -r
2.6.32-71.el6.i686 (Scientific Linux on VirtualBox)

-bash-4.1$ df -k
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/vg_server01-lv_root
                   9813128   8531992    788812  92% /
tmpfs                   141120         0    141120   0% /dev/shm
/dev/sda1               495844     28678    441566   7% /boot

-bash-4.1$ ls
TestACL

-bash-4.1$ pwd
/home/ssagar

-bash-4.1$ mount
/dev/mapper/vg_server01-lv_root on / type ext4 (rw,acl)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
/dev/sda1 on /boot type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)

Any ideas how I can fix this?

share|improve this question
1  
1. Need df -k (inodes are interesting but do not tell the very much) 2. What device/disk is TestACL on? Without these two pieces it is hard to help you. –  mdpc Oct 6 '11 at 21:55
    
Thanks mdpc! Please read the updated description. The filesystem in 92% full and the file in on /home/ssagar. I setup this server for RHSA exam practice. –  user97132 Oct 7 '11 at 10:09
    
hmmm....one more item, show the /etc/fstab. There is sometimes an option that disables using ACLs as well as the filesystem types that do not support ACLs. –  mdpc Oct 7 '11 at 18:50
    
Sorry, had a long weekend. I've updated the description with mount output. Thanks! –  user97132 Oct 11 '11 at 13:43
add comment

1 Answer

Two thoughts:

  1. Have you run fsck on the file system?
  2. This is a long shot, but could there be a long list of existing ACLs, either on the TestACL directory or overall in /home?
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.