Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using Scientific Linux 6 and am installing the following desktop-related package groups:

@basic-desktop
@desktop-platform
@general-desktop
@x11

However, after installation, /etc/inittab still set to multi-user console runlevel (id:2:initdefault:).

What am I missing here?

share|improve this question

2 Answers 2

Good question. You're using a kickstart. Can you post the full file? I've typically found that kickstart files run in text mode will result in a system that boots to runlevel 3. If you omit the text mode installation and install the requisite desktop/x11 groups, the system should default to runlevel 5.

Of course, you can add a line in the postinstall section, too...

sed -i 's/id:2:initdefault:/id:5:initdefault:/g' /etc/inittab

share|improve this answer
    
I was wondering about the text option as well (I am using it). According to the documentation though, that is only for the installation mode. Misdocumented perhaps? The post-install would be a last resort. The machine is at work so I will post the entire kickstart file later tomorrow morning. –  Belmin Fernandez Oct 6 '11 at 23:28
    
Remove the text option and you'll get a graphical kickstart, but the installation will come up in runlevel 5. –  ewwhite Oct 6 '11 at 23:33
    
Just tried that on a machine here at home. Did not work unfortunately. Will try again at work with that kickstart file but I'm not hopeful anymore. –  Belmin Fernandez Oct 7 '11 at 3:38
    
I don't have a specific package/file, but why not do one install in graphical and one in text, and compare what files are different between the two? Once you know the differences, you can use 'yum whatprovides' and hopefully find out what the missing package is. –  devicenull Oct 7 '11 at 3:59
    
@devicenull That was the exact process I went through and how I narrowed it down to those package groups. I submitted an answer that I will check into later on. Weird that the graphical installs I've done don't have that option in the anaconda.ks though. Shrug –  Belmin Fernandez Oct 7 '11 at 4:27
up vote 3 down vote accepted

Hate to answer my own question but I think I found something that might be it. The xconfig option with the --startxonboot parameter seems to fit perfectly.

I will test it in the morning.

share|improve this answer
    
Eureka! Worked. Weird that a normal install that does configure default runlevel 5 does not print out that option in the anaconda.ks file. Oh well. –  Belmin Fernandez Oct 7 '11 at 16:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.