Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have some servers that are running Virtuozzo 3.x on them still. This is VERY old and starting to cause some serious problems. The machines are leased machines in a datacenter in TX while I am in WI so I am trying to upgrade with vzup2date.

The update process finished downloading the packages it needed but as soon as it tries to install them it fails with a message about not being able to stop Virtuozzo. I manually stopped vz using /etc/init.d/vz stop and it claimed to have successfully shutdown. I then re-ran the vzup2date process and it failed at the same point with the same error even though Virtuozzo is stopped.

I tried to prevent vz from booting with the system using chkconfig vz off and rebooting. Regardless vz was still running after a reboot of the hardware node. I stopped vz manually again and tried to re run vzup2date to perform the upgrade and it failed with the same error.

Out of curiosity I ran /etc/init.d/vz status and it reported vz was still running even though it reported it successfully stopped in the previous step. I took a look at the init script and found the command that it uses to test if it was running or not. I thought perhaps there was a pid file that was not being deleted or something along those lines but that was not the case. It checks for vzmon in /proc/modules and if anything returns it reports as running.

Before stopping VZ I get the following results:

[root@server /]# grep vzmon /proc/modules 
vzmon 50540 22   vzrst,vzcpt,slm_if,ip_vzredir,vzredir,vzcompat,vzfs,vzethdev,vzevent,vzlist,vzstat,ip_vznetstat,vznet,vznetstat, Live 0xf8e2d000
vzdev 2304 18 slm_if,vzredir,vzcompat,vzdquota,vzfs,vzethdev,vzlist,vznet,vznetstat,vzmon,     Live 0xf8def000

After stopping VZ I get these results:

[root@server /]# grep vzmon /proc/modules 
vzmon 50540 3 slm_if,vznet,vznetstat, Live 0xf8e2d000
vzdev 2304 5 slm_if,vzdquota,vznet,vznetstat,vzmon, Live 0xf8def000

Its obviously removed several modules but not all of them. I tried to stop the vzlmond service and manually remove a couple without any luck.

[root@server /]# /etc/init.d/vzlmond stop
Stopping vzlmond: [FAILED]

[root@server /]# rmmod vzmon 
ERROR: Module vzmon is in use by slm_if,vznet,vznetstat

[root@server /]# rmmod vznet
ERROR: Module vznet is in use

[root@server /]# rmmod vznetstat
ERROR: Module vznetstat is in use by vznet

The datacenter was less than helpful in helping resolve this issue.

share|improve this question

vzup2date won't run if your service container is not started. This sounds like your SVE is borked. I would start recreating it first.

try using this:

It seems that you are in a weird situation. If I were you, I would install a new hardware node with the same application templates and then migrate your containers manually. vzup2date is not the best way to go in between major releases and in will give you more headache then profit.

Also, parallels advise the same. Do you also use POA? It would help while you migrate. You can also try using the vzmigrate for different manual solutions.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.